6 Replies Latest reply on May 28, 2017 7:41 AM by Delfer

    Lightroom refuses to start

    Delfer

      Problem: When I start Lightroom, the splash-screen flashes briefly, but Lightroom refuses to start!

       

      System Info: iMac 27" 5K, macOS Sierra (10.12.5), fully decked with AMD Radeon R9 M390 2048 MB GPU, 32 Gb RAM, 1Tb SSD, 9Tb external RAID storage

       

      Background information: Yesterday Lightroom was working fine. Just finished importing 4000+ images from various memory cards of three different cameras (from an assignment), added them all to a catalog, and rendered standard previews. Upon closing Lightroom I backed up my Library. Today when I started lightroom the splash-screen flashed briefly and Lightroom refuses to start. I noticed there was an update to Lightroom (6.10.1) available under the CC icon in the top-bar (as well as Adobe Camera RAW). So I updated both, and tried to relaunch to no avail.

       

      What have I tried so far: I have read and followed all suggestions I could find on this issue, nothing helps. Here are some of the things I have tried:

       

      • Signed out of Creative Cloud -> Signed back in
      • Uninstalling Lightroom -> Reinstalling Lightroom
      • Opening a different Library in Lightroom
      • Resetting Lightroom settings to default (Shift+Option+Delete when launching Lightroom)
        • This actually lead to a crash and a crash report (that I copied before sending, although it doesn't make much sense to me)
      • Disabling allowing Lightroom to use the GPU

       

      NONE of the above proposed fixes and solutions have worked for me, and I am at my wits end. Making matters worse, I am on a deadline to sort through the 4000+ images, make a few adjustment to the images and export them in various resolutions, so I can deliver images to my client.

       

      Any help would be GREATLY appreciated!

       

      With best regards

       

      Henrik Delfer

        • 1. Re: Lightroom refuses to start
          cmgap Adobe Community Professional

          Have you rebooted your iMac? Are your 4k images on your local drive or an external drive? When did you last backup your Lr catalog?

          • 2. Re: Lightroom refuses to start
            Delfer Level 1

            Thank you cmgap..

             

            • iMac have been rebooted several times
            • The images imported successfully in Lightroom yesterday
            • Images reside on an external Galdigit 9Tb RAID drive (but even a different catalogue with <50 images stored internally on the SSD wont load)
            • Lightroom Catalogue was backed up yesterday (I cannot open the previous catalogue either or any other catalogue for that matter)

             

            - Henrik

            • 3. Re: Lightroom refuses to start
              cmgap Adobe Community Professional

              Do you have any 3rd party plugins installed and stored with the catalog? If yes, try removing them, disconnect all externals and reboot and open Lr from your CC Manager (not from your dock). Post a screen shot of the error message if you get one.

              • 4. Re: Lightroom refuses to start
                Delfer Level 1

                I do use 3rd party plugins, but I am not sure how to disable them, as I cannot even get Lightroom to start. Besides... I thought resetting all Lightroom settings (which I have done) should disable all plugins as well?

                 

                I cannot disconnect the external drive as it is also my application, system and user drive.

                • 5. Re: Lightroom refuses to start
                  cmgap Adobe Community Professional

                  It's possible that you may have a 3rd party plugin that is not compatible with the newest version of Lr.  Most plugins also come with an uninstaller. If not locate the Lr Plugins folder and manually move the 3rd party plugins out of the folder into another temp folder. Try to open Lr again. Check the website of the 3rd party plugins that you purchased to see if they have an  updated version that runs with the latest update. 

                  • 6. Re: Lightroom refuses to start
                    Delfer Level 1

                    Found the solution after reading cmgap last response :-)

                     

                    From what I could gather, this is what happens:

                    It seems Lightroom expects that there is a physical Documents folder in the User directory. It is not the Document Folder itself that Lightroom uses, but the Library Subfolder. The Library folder CAN actually be moved to a different location (if you want to), and Lightroom will happily accept that, but if you then move your Documents folder, Lightroom cannot start.

                     

                    Lightroom does NOT inform the user that this folder is missing, when it cannot locate it during startup. Instead it simply quits.

                     

                    I had moved my Documents folder out of my User folder this morning, because I wanted to do a bit of cleanup on my harddrive. I had NO IDEA that this would break Lightroom's ability to run. I discovered that a Plugin could be located in the Documents folder (or that System Library information could possibly be located there), and although my System Library is in a different location, Lightroom seems to expect that the Documents Folder is located where it is supposed to be, and refuses to launch if things are not so.

                     

                    Odd that Adobe hasn't included debug code to handle a missing folde like the Documents folder, even though it may not even use it to store anything.

                     

                    Thanks for your help cmgap! Although you did not directly solve the problem, your response regarding Plugins led me to the solution.

                     

                    - Henrik