7 Replies Latest reply on Oct 7, 2008 9:40 AM by stl_writer

    Why are DHTML options suddenly grayed out?

    stl_writer
      Hello, I'm trying to figure out why, when I opened RH7 today, and I tried to create a new drop-down hotspot in a topic, the hotspot options under the DHTML menu are suddenly grayed out.

      I'm thinking this is a result of upgrading to Flash player activex 9. Right after I did that, my laptop (including but not limited to RH7) began to spit out the message "flash.ocx not found" or something along those lines.

      Someone said to take Flash9f.ocx (the newest incarnation), copy it to a file named flash.ocx, and place it where the current Flash9f.ocx is housed. Well, it got rid of the annoying message, but RH7 still isn't working right.

      Does this problem sound familiar to anyone, and if so, do you have a fix?

      I thought of uninstalling Flash Player ActiveX, but I don't have a previous version I could re-install.

      Thanks for any assistance.

      Lori
        • 1. Re: Why are DHTML options suddenly grayed out?
          Captiv8r Adobe Community Professional & MVP
          Hi there

          Personally, I'd be totally surprised if that were the issue. I believe it's a red herring.

          Normally most of the options are disabled if you have no text selected first. So the question would be to ask if you have selected text prior to clicking the DHTML menu?

          Cheers... Rick
          • 2. Re: Why are DHTML options suddenly grayed out?
            stl_writer Level 1
            Hi, Rick,

            Yes, I selected text. It's like my projects have just suddenly lost the hotspot capability. Weird.
            • 3. Re: Why are DHTML options suddenly grayed out?
              Captiv8r Adobe Community Professional & MVP
              Hi again

              Things I might try:

              * Close and restart RoboHelp
              * Try nominating a different layout to be the default

              Give those a go and see if they help anything... Rick
              • 4. Re: Why are DHTML options suddenly grayed out?
                stl_writer Level 1
                Rick,

                Since I'm having this error with both of my existing projects (which have had no drop-down hotspot problems until now), I created a new project altogether. The drop-downs work fine in the new project, which just defaults to whatever a new project defaults to.

                I don't understand what you mean by "nominating a different layout" to the existing projects. Can you clarify? Because I still don't understand what suddenly changed in my existing projects that made them stop supporting the drop-downs.

                Thanks again.

                Lori
                • 5. Re: Why are DHTML options suddenly grayed out?
                  RoboWizard Level 4
                  Hi Lori

                  If you examine the Single Source Layouts pod you will see several layouts. I'm suggesting you right-click any other layout and choose the option labeled "Set as primary layout". So try that and see if it changes anything. Alternatively, you may wish to try creating a totally new layout. To do this, you right-click and choose the option labeled "New Layout...".

                  Hopefully this was helpful... Rick
                  • 6. Re: Why are DHTML options suddenly grayed out?
                    Amebr-ke0mH4 Level 2
                    I've had problems with the options being greyed out if I select an entire paragraph, including the (usually hidden) paragraph mark. Mostly that only happens on bulleted or numbered paragraphs thought. Selecting the text without the paragraph re-enables the drop-down options.

                    Just thought I'd throw that in as an idea, just in case.
                    • 7. Why are DHTML options suddenly grayed out?
                      stl_writer Level 1
                      Well, as it turns out, I think Amebr is on to something. There was some unexpected tagging when I finally decided to review the HTML code.

                      The text I was working with was a table of drop-downs that I had copied from another topic. I deleted all but one of the drop-downs, filling the remaining one with new text. Then I added additional, new drop-downs. But as I examined the HTML code later (finally), I noticed, for example, that there was a dropdown hotspot tag where there should not have been one. I'm not sure if it was embedded or what. And even after I removed this extra tagging, there were still some problems. (And yes, Amebr, some of the text included bulleted and numbered lists.)

                      I eventually just scrapped all of the copied text, keeping only the table framework, and typed in everything from scratch. The problem resolved.

                      Thanks to all for your help.