3 Replies Latest reply on Oct 4, 2008 2:44 AM by Newsgroup_User

    loadMovie not working online

    robner357
      I have a flash CS3 / as2 website with a page in it that is using a frame script

      loadMovie("video", "mc");
      where "mc" is the name of a blank movie object

      It works just fine offline, but I cannot get it to work online.

      The video.swf is loading online, but it will not load the video.flv while on the webserver.

      I have many other flash videos on this server, so its not a mime problem with the server.
      There is just some quirk I am not seeing.

      Would love it if anyone has any insights, tests to run, etc...

      Thanks

      Rob
        • 1. loadMovie not working online
          robner357 Level 1
          Just another note.

          I tested navigating a path directly to the video.swf, (bypassing the flash website and loadMovie script) and the video.swf loads jsut fine as I have a simple grey oval in it for visual verification, but when I navigate directly to the video.flv I just get a white browser page. When I navigate to another .flv that IS working in another flash website properly, I get the download dialog box.

          ***I think this is telling me that if the video.flv wiill load properly, navigating to the video.flv directly will allow you to download it.

          I am going to try and re-render the .flv and try again. This is so weird because everything plays just fine offline on my local machine.

          Rob
          • 2. Re: loadMovie not working online
            Level 7
            robner357 wrote:
            > I have a flash CS3 / as2 website with a page in it that is using a frame script
            >
            > loadMovie("video", "mc");
            > where "mc" is the name of a blank movie object

            The above seem odd. Video should follow .swf or .jpg or something. Unless you missed
            that extension while writing the mail, it isn't a correct syntax.
            You need to specify the exact file name as this method is for externally loaded content.

            loadMovie("video.swf", "mc");




            --
            Best Regards

            Urami


            --
            "Never play Leap-Frog with a Unicorn."


            <urami>
            If you want to mail me - DO NOT LAUGH AT MY ADDRESS
            </urami>
            • 3. Re: loadMovie not working online
              Level 7
              robner357 wrote:
              > Just another note.
              >
              > I tested navigating directly to the .swf, (bypassing the flash website) and it
              > loads, but when I navigate directly to the .flv I just get a white browser
              > page. When I navigate to another .flv that IS working in another flash
              > website, I get the download dialog box.

              Could it be path mismatch?
              Html load SWF from sub directory and not the same folder where the html itself lays?



              --
              Best Regards

              Urami


              --
              "Never play Leap-Frog with a Unicorn."


              <urami>
              If you want to mail me - DO NOT LAUGH AT MY ADDRESS
              </urami>