5 Replies Latest reply on Mar 29, 2016 4:34 AM by txemam26262263

    Different internet browsers issues

    txemam26262263 Level 1

      Hi,

      I am setting up different target activities for my own website and I am finding some troubles depending on which browser I use. I commonly use Google Chrome, but I have been forced to use Mozilla Firefox and Internet Explorer 11 as well.

      For example, I only can create and edit the target activities using Firefox. When Adobe Target tries to open my site with Chrome and through the public URL it doesn't succeed (error message: "The selected website is taking too long to load or does not contain Target libraries"). I always enable mixed content by the way.

      Another case is when I open the experiences preview, for instance of a Experience Targeting activity. I can only load the preview properly if I open it in Internet Explorer 11. Additionally, this is the only browser that shows my a Test&Target item at the Debugger at the public URL.

      I keep trying to make my target activities work. Unfortunately, when I simulate my website with different user profiles of the ContextHub in the Author version it doesn't show any experience from Adobe Target. I have follow all the steps specified in the documentation and help resources, but I am probably missing something or doing something wrong.

      Are these "multiple-browser issues" common? I would do appreciate any clue or tip to find the source of my problems.

      Thanks.

        • 1. Re: Different internet browsers issues
          Shekhar_Dhiman Adobe Employee

          Hi There,

          Thanks for reaching out.

          If your page does not display the expected content, there are a few steps you can take to debug content delivery.

          • Check your activity or campaign code carefully. A typo or other error could cause the expected content not to display.
          • Use mboxTrace or mboxDebug to troubleshoot the mbox.

          mboxDebug is especially useful when you are setting up Target on your page to make sure the mbox is firing and the cookie is being set. However, it does not go into the kind of detail that is useful when debugging content delivery. If your activity does not appear on your page or undesired content appears, use mboxTrace to examine and debug the page in detail.

           

          Please see this doc for more:

          https://marketing.adobe.com/resources/help/en_US/target/target/c_content_trouble.html

          • 2. Re: Different internet browsers issues
            txemam26262263 Level 1

            Thank you for your reply. Despite all I have checked my code and used the MboxDebugger but I can not find the problem yet.

            We think that the problem source could be the Adobe Target implementation. Therefore, I copy down below the code that we have added to our site. Previously, we have set up the Configuration and Framework of my site in the Cloud Services and, after downloading both VisitorAPI.js and AppMeasurement.js and modifying them, we added the following code in the page:

            • The head section:
            <cq:include script="/libs/cq/cloudserviceconfigs/components/servicelibs/servicelibs.jsp"/> <script language="JavaScript" type="text/javascript" src="/content/VisitorAPI.js"></script> <cq:include script="/libs/cq/cloudserviceconfigs/components/servicelibs/servicelibs.jsp"/> <script language="JavaScript" type="text/javascript" src="/etc/cloudservices/testandtarget/my-target-configuration/jcr:content/public/mbox.js"></script> <script language="JavaScript" type="text/javascript" src="/content/AppMeasurement.js"></script>

             

            • The body section (start):
            <cq:include path="clientcontext" resourceType="cq/personalization/components/clientcontext"/>

             

            • The body section (end):
            <cq:include path="cloudservices" resourceType="cq/cloudserviceconfigs/components/servicecomponents"/>

             

            The Mbox Debugger shows the following results for the different Internet browsers:

            • Internet Explorer 11

            • Google Chrome and Mozilla Firefox:

            Page: http://aem-b2c-app-q3.cloudapp.net/content/telco.html?mboxDebug=1 Referrer: • Enabled: false • Cookies: 'shownotification=true; _gu=785c3e10-2e5f-4dd5-ac3e-c73c49932832; _gw=2.59789(sc~3,s~o33lne)59791(sc~3,s~o33lne)u[~0,~0,~0,~0,~0]v[~eg9cz,~3,~0]a(); SessionPersistence=PROFILEDATA%3A%3DauthorizableId%253Daparker%2540geometrixx.info%7CCLIENTCONTEXT%3A%3DvisitorId%253Daparker%2540geometrixx.info' • Factory: 'default' o pageId: 1458227486010-921704

            • 3. Re: Different internet browsers issues
              txemam26262263 Level 1
              • Google Chrome and Mozilla Firefox:

              [img]MboxDebugger Chrome & Firefox.png[/img]

              • 4. Re: Different internet browsers issues
                txemam26262263 Level 1

                In addition, I attach the results from the Adobe Marketing Cloud Debugger both for Firefox and IE11

                • Firefox:

                • Internet Explorer 11

                • 5. Re: Different internet browsers issues
                  Siddharth.J Adobe Employee

                  You may be facing issues with Chrome due to a known issue. The Chrome version 48 update introduced an issue that causes the Visual Experience Composer to function incorrectly in Chrome. Google is working on a solution. For information, refer to https://code.google.com/p/chromium/issues/detail?id=582603. To work around this issue:

                  • Use Firefox or Internet Explorer.
                  • Enable the Enhanced Experience Composer, which can be configured from within the Setup > Preferences tab.