5 Replies Latest reply on Dec 12, 2016 3:06 AM by JatinG

    Auto save functionality not working

    JatinG

      Hello All,

      I am trying to use default auto save feature in AEM forms but its not working as expected. As per my opinion if auto save is enabled, then even on browser refresh, the form must retain the information. But this is not happening, even if I checked the auto save option both for anonymous as  well as signed in user.  Although, I can see the data being saved under metadata folder but the form is not populating. 

      Any suggestions.

        • 1. Re: Auto save functionality not working
          gauravahuja11 Level 1

          Hi, If the data and metadata are being stored in the drafts node, then the auto save functionality is configured correctly. You're refreshing the adaptive form window that has the adaptive form url, but this url is only for the form and does not contain any information about how to prefill the form. It wont open a form with the saved values. To open a saved form (i.e. draft), normal refresh won't work. You will have to open the draft from the location where the drafts/submissions on your system are stored. By default, the location for drafts/submissions is - http://:/content/geometrixx-gov/en/applications/myforms.html .

          • 2. Re: Auto save functionality not working
            anu_jain

            Hi Jatin,

            From your post it looks like metadata is being saved from the autosave feature, could you please confirm whether the data is getting saved or not, userdataID property would be present in the metadata node if data was saved properly.It would be of great help if you could give us some information for the below questions

                1. Set up information and event based or time based autosave is being used.

                2. Confirm if data is being saved or not along with metadata by checking userdataID and manually checking user data folder.

                3.If data is present also then does it throw any error while rendering the draft ? attach the logs if available.

            Thanks,

            Anul

            • 3. Re: Auto save functionality not working
              JatinG Level 1

              Hi Anul,

              1. Configuration is Time based

              2. userDataId exists for each node under /drafts/metadata

              3. No error is being seen either on console or logs

              When I am using the metadata path as URL to render the form, the empty form is rendered.

              • 4. Re: Auto save functionality not working
                JatinG Level 1

                Hi Gaurav,

                Even I am trying to use metadata path as URL to pre-populate the form, the empty form is getting rendered.

                • 5. Re: Auto save functionality not working
                  JatinG Level 1

                  Hi Gaurav,

                  Even I am trying to use metadata path as URL to pre-populate the form, the empty form is getting rendered.