8 Replies Latest reply on Oct 15, 2015 7:30 PM by daleschimpf

    E-Sign Component Rendering Issue (Echosign) After Submit Button is Clicked and Validation Fails

    daleschimpf Level 1

      Hi:

      I've posted about this issue before but I think it got lost in the shuffle a bit as I was also trying to deal with some other adaptive form issues as well (now resolved thanks to this forum's help).

      I'm having an issue across multiple forms using 2 different form templates I have tried that come with AEM Forms (Advanced Enrollment Adaptive Form Template & Tabbed Enrollment Adaptive Form Template).

      Simply stated, what is happening is this: If I try to submit a form that has required fields, before all required fields have been filled out, and I have previously navigated to the panel containing the E-Sign Component at least once (and the form has been rendered inside the component), navigating to the E-Sign Component again results in the component failing to re-render the form anymore, even after dismissing the components alert box which pops up and says "Please esign the form".

      Perhaps the simplest thing to do is to convey the steps I have taken to get to this point so that you may recreate the issue yourself:

      1. Create a new adaptive form based on either one of the 2 above mentioned templates (they both come with the E-Sign Component sited on them by default).
      2. Associate the form with an XFA form.
      3. Set at least one field on the form (text or numeric field for example) to be required.
      4. Configure the E-Sign Componenet to use the Echosign service (obviously one will need an Echosign account setup and configured in AEM already).
      5. View the form in Preview mode
      6. Navigate to the panel containing the E-Sign component (the form should render fine inside the component)
      7. Click the Submit button on the form.
      8. Dismiss the "Please esign the form" alert box from the E-Sign Component.
      9. Navigate to any other panel on the form and then back to the panel containing the E-Sign Component.
      10. The E-Sign Component will no longer render the form anymore during that session.

      Can anyone provide some insight into this? Is this a known issue? Is this a bug? Is there a workaround?

      I've also tried using the Verify Component and that always seems to re-render the XFA form no matter what.

      Any help you can provide would be most appreciated.

      Dale

      • 0. Re: E-Sign Component Rendering Issue (Echosign) After Submit Button is Clicked and Validation Fails
        daleschimpf Level 1

        Hi Mandeep:

        Please look for a private forum message I just sent you regarding this.

        Thanks

        Dale