6 Replies Latest reply on Apr 4, 2016 10:43 PM by alexandrad27705859

    Render Error on Submit

    alexandrad27705859 Level 1

      Hi, 

      I have an adaptive form which I have been working on for some time. I also have a XDP base template to generate the DoR. My form has the "store PDF action" configured and generating the DoR has worked fine for some time now. All of the sudden I am getting errors when submitting the form and don't know what is going wrong because the entire stack trace is pointing towards AEM classes.

      04.04.2016 15:55:50.892 *ERROR* [0:0:0:0:0:0:0:1 [1459749350227] POST /content/forms/af/my-company/my-form/jcr:content/guideContainer.af.submit.jsp HTTP/1.1] com.day.cq.wcm.core.impl.WCMDebugFilter Exception: null
      com.adobe.aemds.guide.service.GuideException: null
          at com.adobe.aemds.guide.servlet.GuideSubmitServlet.doPost(GuideSubmitServlet.java:254)
          at org.apache.sling.api.servlets.SlingAllMethodsServlet.mayService(SlingAllMethodsServlet.ja va:149)
          at org.apache.sling.api.servlets.SlingSafeMethodsServlet.service(SlingSafeMethodsServlet.jav a:345)
          at org.apache.sling.api.servlets.SlingSafeMethodsServlet.service(SlingSafeMethodsServlet.jav a:376)
      ....
      Caused by: com.adobe.aemds.guide.service.GuideException: null
          at com.adobe.aemds.guide.addon.service.impl.GuidePDFSubmitHelperImpl.getWrappedParameterMapF orPdfSubmit(GuidePDFSubmitHelperImpl.java:147)
          at com.adobe.aemds.guide.servlet.GuideSubmitServlet.doPost(GuideSubmitServlet.java:155)
          ... 131 common frames omitted
      Caused by: com.adobe.forms.service.LCFormsServiceException: null
          at com.adobe.forms.service.impl.LCFormsOsgiServiceImpl.render(LCFormsOsgiServiceImpl.scala:9 2)
          at com.adobe.forms.service.impl.LCFormsServiceImpl.render(LCFormsServiceImpl.java:79)
          at com.adobe.aemds.guide.addon.service.impl.XFAModelTransformerImpl.getPdfFromXfaDom(XFAMode lTransformerImpl.java:176)
          at com.adobe.aemds.guide.addon.service.impl.GuidePDFSubmitHelperImpl.getWrappedParameterMapF orPdfSubmit(GuidePDFSubmitHelperImpl.java:112)
          ... 132 common frames omitted
      Caused by: java.lang.Exception: PAExecute Failure: XFA_RENDER_FAILURE
          at com.adobe.forms.aem.impl.XFANativeServiceImpl.paExecute(XFANativeServiceImpl.java:162)
          at com.adobe.forms.aem.impl.XFANativeServiceImpl.paExecute(XFANativeServiceImpl.java:430)
          at com.adobe.forms.xtg.impl.XMLFormServiceImpl$$anonfun$paExecute$2$$anonfun$2.apply(XMLForm ServiceImpl.scala:167)
          at com.adobe.forms.xtg.impl.XMLFormServiceImpl$$anonfun$paExecute$2$$anonfun$2.apply(XMLForm ServiceImpl.scala:167)
      ....

      Can anyone point me in the right direction? How can I find out what is wrong with the form?

      Any help is greatly appreciated! Thanks, 

      Alex

        • 1. Re: Render Error on Submit
          nitin.nizhawan Level 2

          Hi Alex,

            It usually means some issue with either XDP, data or fonts. Exact cause of this error is printed just before this exception in logs. If you can share entire error.log file from crx-quickstart/logs/ then we should be able to help in identifying the root cause.

          Thanks

          Nitin

          • 2. Re: Render Error on Submit
            alexandrad27705859 Level 1

            Hi Nitin, 

            Thanks for your quick response!

            I've attached more of the error.log. There is something with "The SOM expression '$record.Accomomodation[*]' for the dataRef specified on field 'Accomomodation', resolved to an incompatible node type of 'dataValue'." Not sure if this is the problem and what it means. Accommodation is a repeatable panel which should be rendered as a table in the DoR...But I haven't made any changes to that, so not sure if this is really the problem. 

            Any help is very appreciated because I don't have the time to start all over with the form!

            Thanks, Alex

            • 3. Re: Render Error on Submit
              alexandrad27705859 Level 1

              Update:

              I found the issue why there is an error when generating the DoR: I have a checkbox at the beginning of the form which shows/hides a child panel (Accommodation) of the form. If this panel is hidden (and the Form has "Exclude fields from DoR if hidden" checked) it comes up with the error: "The SOM expression '$record.Accomomodation[*]' for the dataRef specified on field 'row', resolved to an incompatible node type of 'dataValue' "

              I've tried setting the visibility of the fields in that panel to false when the panel's visibility is false but that doesn't make a difference. 

              Has anyone come across this? Is there a way to fix this?

              Thanks, Alex

              • 4. Re: Render Error on Submit
                sachjain Level 1

                Hi Alex,

                What is the version of Adaptive Form you are using? If you could share Adaptive form and XML Schema to find out the cause of the issue, would be very useful resource to fix the issue.

                Thank You,

                Sachin Jain

                • 5. Re: Render Error on Submit
                  sachjain Level 1

                  One question, are all fields under Accommodation panel bound to attributes i.e. their bind references contain '@'?

                  • 6. Re: Render Error on Submit
                    alexandrad27705859 Level 1

                    Hi Sachjain,

                    None of my fields in the form are bound and have no bind references. I am using AEM 6.1 Forms (JEE). 

                    I can package the form and send it to you via email. 

                    Thanks, 

                    Alex