5 Replies Latest reply on Oct 15, 2015 7:30 PM by raghav gupta

    AEM Adaptive Forms - Analytics Integration/Report

    victor.toledo_dh

      Hi all

      I'm working with AEM Form, i have some forms created. Now i'm trying to integrate them with Analytics. The integration is working, I am getting the data on my SiteCatalyst Report Suite and i can display them on my graphics.

      The problem is with the Summary Report into AEM. When i select the form and i clicked on Analytics Report, i get "No analytics data found for the selected date range."

      [img]2015-06-24_15-38-36.png[/img]

      and searching on my error.log i found this exception:

      com.adobe.aem.formsndocuments.analytics.report.util.ReportingUtils JSONException while creatiing the result object
      org.apache.sling.commons.json.JSONException: JSONObject["globalData"] not found.
       at org.apache.sling.commons.json.JSONObject.get(JSONObject.java:372)
       at org.apache.sling.commons.json.JSONObject.getJSONObject(JSONObject.java:466)
       at com.adobe.aem.formsndocuments.analytics.report.util.ReportingUtils.replaceHashWithSom(Rep ortingUtils.java:183)
       at com.adobe.aem.formsndocuments.analytics.report.servlet.AnalyticsReportingServlet.getRepor tJson(AnalyticsReportingServlet.java:171)
       at com.adobe.aem.formsndocuments.analytics.report.servlet.AnalyticsReportingServlet.doPost(A nalyticsReportingServlet.java:86)

      org.apache.sling.engine.impl.SlingRequestProcessorImpl service: Uncaught SlingException
      java.lang.NullPointerException: null
       at com.adobe.aem.formsndocuments.analytics.report.servlet.AnalyticsReportingServlet.getRepor tJson(AnalyticsReportingServlet.java:175)
       at com.adobe.aem.formsndocuments.analytics.report.servlet.AnalyticsReportingServlet.doPost(A nalyticsReportingServlet.java:86)
       at org.apache.sling.api.servlets.SlingAllMethodsServlet.mayService(SlingAllMethodsServlet.ja va:148)
       at org.apache.sling.api.servlets.SlingSafeMethodsServlet.service(SlingSafeMethodsServlet.jav a:344)
       at org.apache.sling.api.servlets.SlingSafeMethodsServlet.service(SlingSafeMethodsServlet.jav a:375)
       at org.apache.sling.engine.impl.request.RequestData.service(RequestData.java:533)
       at org.apache.sling.engine.impl.filter.SlingComponentFilterChain.render(SlingComponentFilter Chain.java:45)
       at org.apache.sling.engine.impl.filter.AbstractSlingFilterChain.doFilter(AbstractSlingFilter Chain.java:64)
       at com.day.cq.personalization.impl.TargetComponentFilter.doFilter(TargetComponentFilter.java :96)

      I configured the "AEM Forms Analytics Configuration" (see attached image)

      [img]2015-06-24_15-39-53.png[/img]

      any idea?

      Thanks in advance

      • 0. Re: AEM Adaptive Forms - Analytics Integration/Report
        raghav gupta

        victor.toledo_dh wrote...

        raghav gupta wrote...

        Are you still getting this error ? Is this Adaptive Form or Mobile Form ? Can you try after deleting analytics cached data i.e. deleting "analyticsdatanode" node ? It should be similar to this path - /content/dam/formsanddocuments/<formPath>/jcr:content/metadata/analyticsdatanode

         

        YES!!! Is working, you saved me. 

        One thing to add, i deleted the node on /content/dam/formsanddocuments/<formPath>/jcr:content/analyticsdatanode, into metadata the node analyticsdatanode doesn´t exist.

        Thank you very much, raghav gupta

        smiley

         

        Yes, you deleted the correct node. It was a typo error.