4 Replies Latest reply on Jul 12, 2017 7:59 PM by Ussnorway

    Shopify Embed Button Slow

    GGR-stephanie

      Is there a way to speed up the load time of Shopify embed Buy Buttons? I have over 70 products on one page, so I have that many buy buttons (just the button, no product image). This leads the page to load very slow, and even stop working. Is there anything I can do to fix this?

       

      Here is my product page:

      http://wasp-1.businesscatalyst.com/accessories.html

        • 1. Re: Shopify Embed Button Slow
          Preran Adobe Employee

          Hi Stephanie,

           

          You will have to contact the widget developer to see if there is an issue with it.

           

          Thanks,

          Preran

          • 2. Re: Shopify Embed Button Slow
            bradleyl65971045

            It Seems like normal behaviour. The shopify script is loading from a different location and there is no another way to control its functioning.

            • 3. Re: Shopify Embed Button Slow
              Jeffrey_Smith Most Valuable Participant

              I have a similar site, with 5-25 Shopify buy buttons per page, and have on occasions noticed longer load times of the buttons.

               

              First call was to hosting company, but since the non-shopify content loaded normally, with shopify buttons lagging, they had no resolve. I then made the call to Shopify tech support, but since the issue was sporadic, they also had no resolve.

               

              When noticing the buy buttons loading slowly on site, I have gone into my shopify account (to which the buy buttons are associated) and have noticed the same diminished access.

              2 people found this helpful
              • 4. Re: Shopify Embed Button Slow
                Ussnorway Adobe Community Professional

                GGR-stephanie  wrote

                 

                Is there a way to speed up the load time of Shopify embed Buy Buttons?

                not really

                 

                GGR-stephanie  wrote

                Is there anything I can do to fix this?

                I think Jeffery has a point... is it in fact Shopify or something else.

                test:

                split the page into two new pages, one with just the Shopify buttons and the other has the same design elements but all the Shopify buttons removed.

                 

                time the load times of these two pages in different browsers and phones to see what the issue is... wipe the browser history and files after each load.

                1 person found this helpful