2 Replies Latest reply on Feb 20, 2018 6:45 AM by alexm89209855

    Create a workflow agreement via REST API

    pet exom Level 1

      Hi,

       

      I am trying to start a workflow via a rest call

      {{base_api_url}}{{api_version}}workflows/{{workflowId}}/agreements

      with the minimal requirments like

      {

        "documentCreationInfo": {

          "fileInfos": [

            {

             "name": "[DEMO USE ONLY] Disclaimer",

              "workflowLibraryDocumentId": "3AAABLblqZhDaZYAALm66_cvqNPonPiFmYIKQK3Ez4-iBRIFiLmZYS0kf5FsXkg9IA7pniNZsafq_R9LCajE3e4b AgN0MVZxJ"

            }

          ],

          "name": "566931d2ca32f2d17dabce4cae7e1fd4",

          "recipientsListInfo": [

            {

              "name": "User",

              "recipients": [

                {

                  "email": "smo-test@test.com"

                }

              ]

            }

          ]

        }

      }

       

      But I am retrieving a Server error

      {

        "code": "MISSING_REQUIRED_TO_FIELD",

        "message": "Required ToField tos is missing"

      }

      What does this error message means? Didn't find any To field in the full description of the request Body.

       

      I have created a simple workflow with one document and signer.

       

      Do I have to create an transient Document before or is this created via the workflow request?

       

      If I run the workflow via the Website it works fine.

       

      Thanks for any hints

       

        • 1. Re: Create a workflow agreement via REST API
          alexm89209855 Level 1

          Hi! Did you manage to solve this issue?

          I'm getting the same error MISSING_REQUIRED_TO_FIELD but on the same call with the same parameters, I get INVALID_WORKFLOW_ID sometimes.

          It seems like a very generic error and it doesn't give you a hint in any direction for where you should look.

          • 2. Re: Create a workflow agreement via REST API
            alexm89209855 Level 1

            As I think MISSING_REQUIRED_TO_FIELD will redirect most of the users to this unanswered question I will post the answer here.

            After contacting the support guys from Adobe I found out that you have to actually fill in the email fields from the workflow page, Recipients tab to avoid this error, even though it's not stated there that you should fill them.

            3 people found this helpful