0 Replies Latest reply on Oct 22, 2008 8:16 AM by borfgordon

    Flex Builder 3.0.1 Eclipse Plugin & Eclipse 3.4.1

    borfgordon Level 1
      Hi,

      I'm using the JEE edition of Eclipse 3.4.1 and FB Plugin 3.0.1. On OS-X Leopard with all latest updates. I have also tried this with a vanilla install of Eclipse 3.4.0 and 3.4.1

      1) unzip a brand new eclispe install
      2) run the plugin installer (no previous plugin install exists)

      1/2 way through the install I get this error:
      “This installation can still be configured manually as a Product Extension” and it gives instructions on how to manually add the plugin and to check the error log

      I hit ok, then it brings up “a newer file named “com.adobe.flexbuilder.debug.e33_3.0.205647.jar” already exists at “/Applications/Adobe Flex Builder 3 Plug-in/eclipse/plugins” Do you want to overwrite this file?

      The error log has the following in it:

      !SESSION 2008-10-22 08:54:01.197 ———————————————–
      eclipse.buildId=M20080911-1700
      java.version=1.5.0_16
      java.vendor=Apple Inc.
      BootLoader constants: OS=macosx, ARCH=x86_64, WS=carbon, NL=en_US
      Framework arguments: -application org.eclipse.update.core.standaloneUpdate -command install -featureId com.adobe.flexbuilder.feature.core.osx -version 3.0.205647 -from file:/Applications/Adobe Flex Builder 3 Plug-in/com.adobe.flexbuilder.update.site/ -to /Applications/Adobe Flex Builder 3 Plug-in
      Command-line arguments: -application org.eclipse.update.core.standaloneUpdate -command install -featureId com.adobe.flexbuilder.feature.core.osx -version 3.0.205647 -from file:/Applications/Adobe Flex Builder 3 Plug-in/com.adobe.flexbuilder.update.site/ -to /Applications/Adobe Flex Builder 3 Plug-in

      !ENTRY org.eclipse.update.core 4 0 2008-10-22 08:54:07.016
      !MESSAGE Featurecom.adobe.flexbuilder.feature.core.osx 3.0.205647cannot be found onfile:/Applications/Adobe Flex Builder 3 Plug-in/com.adobe.flexbuilder.update.site/
      or a newer version is already installed.

      So…. I then startup eclipse and go to open perspective. Nothing there for Flex. So I go to software updates and point to the Flex Builder plugin install folder/eclipse as instructed in the installer error. I setup this new “local site” and proceed to “install” the flex builder plugin through the software update mech.

      “calculating requirements and dependencies….” The software items you selected may not be valid with your current selection…

      Cannot complete the request. See the details.
      Unsatisfied dependency: [com.adobe.flexbuilder.debug.e32 3.0.205647] requiredCapability: osgi.bundle/org.eclipse.debug.ui/[3.2.0,3.3.0)
      Unsatisfied dependency: [com.adobe.flexbuilder.feature.core.osx.feature.group 3.0.205647] requiredCapability: org.eclipse.equinox.p2.iu/com.adobe.flexbuilder.debug.e32/[3.0.205647,3.0.205647]
      Unsatisfied dependency: [com.adobe.flexbuilder.feature.core.osx.nl1.feature.group 3.0.205647] requiredCapability: org.eclipse.equinox.p2.iu/com.adobe.flexbuilder.feature.core.osx.feature.group/[3.0.20564 7,3.0.205647]
      Unsatisfied dependency: [com.adobe.flexbuilder.debug.e32 3.0.205647] requiredCapability: osgi.bundle/org.eclipse.debug.ui/[3.2.0,3.3.0)