2 Replies Latest reply on Jun 2, 2017 6:24 AM by motiondude

    ID CC17 script location mixup

    motiondude Level 1

      Hi there,


      I have both ID CC17 and CS6 installed on my Mac. I'm trying to install a new script (Export FXL HTML) but noticed that CC17 somehow looks at the scripts installed in the CS6 folder. As far as I know you can't set a custom path and if so, I've never set it. So here are my questions:


      • How can I change this so CC17 only looks at the scripts in its own folder?

      • Is it the cause this new script won't show up in my Scripts panel?


      I've tried the Scripts folder (where it should be installed) and the Startup scripts folder. When installed in the Startup folder the script give me an error saying I have no document open (of course, I just launched the app sa what can you expect). What am I missing? Previous installed scrips do show up.


      Thanks in advance.

        • 1. Re: ID CC17 script location mixup
          rob day Adobe Community Professional & MVP

          The Scripts panel has two root folders Application and User.


          Screen Shot 2017-06-02 at 8.50.41 AM.png


          To get script to show under Application the path is:

          /Applications/Adobe InDesign CC 2017/Scripts/Scripts Panel


          For User the path is:

          ~user/Library/Preferences/Adobe InDesign/Version 12.0/en_US/Scripts/Script Panel


          If you put a script in the startup scripts folder it will run when you launch InDesign, so unless the script is designed to run on startup (i.e., it's listening for some event) you would get an error.

          • 2. Re: ID CC17 script location mixup
            motiondude Level 1

            Thanks Rob! I was installing in the application folder. In the Library folder I found out why the other scripts were indicated coming from the CS6 folder. They were all aliases pointing to CS6. Probably with the installation of CC17 the installer made those links. I can't think of anything else. Anyway, it's working now. Thanks!