11 Replies Latest reply on Jun 2, 2017 3:11 PM by Sheryl Checkman

    Issue with Table of Contents Formatting

    Sheryl Checkman

      I have created a TOC in InDesign CC. The paragraph styles that I have to be included in the TOC are:

      1. Heads
      2. SubHeads
      3. Subhead-Group4

      I then created paragraph styles for the TOC:

      1. TOC1
      2. TOC2
      3. TOC3

      I styled each of the TOC 1,2,3 the way I wanted and then in the style area of the TOC dialog box I attributed each of those styles to the Head, Subhead and Sub-head-group 4 respectively. I also created character styles for the page numbers and leaders and also attributed them to each as well.

       

      When I update my Table of Contents however the formatting gets wacky looking. The tabs and indents that were created for each TOC paragraph style is no long applied correctly. Also, the heads seem to revert to the line breaks as they are in the document (which has a shorter column width than the contents) as opposed to the way I broke them in the example attached.

       

      I don't know what I am doing wrong. See below for the want I want it to look.

       

      Please help!!!Screenshot 2017-06-02 12.16.37.png

        • 1. Re: Issue with Table of Contents Formatting
          BarbBinder Adobe Community Professional

          Will you please show your results, with hidden characters visible (Type > Show Hidden Characters). Chances are it will come down to your tab settings, but we need to see what character follows the paragraph numbers to give you specific instructions.

           

          As for the line breaks, InDesign copies the text from the source chapters as is—so if you pressed Sh+Enter to break the lines, then that will be copied to the TOC. Are there soft returns/line breaks in the heads? Alternative ways to control the breaks is that does not impact the TOC:

          1. Use No Break on selected words
            InDesign CCss_012.png
          2. Balance ragged lines on the headings
            InDesign CCss_013.png
          • 2. Re: Issue with Table of Contents Formatting
            Sheryl Checkman Level 1

            Thanks for your response. I will take a look at your suggestions for the line breaks but in the meantime I am attaching my result as well as how I indicated the styles in the dialog box. I am also attaching the way I had formatted it correctly with the hidden characters showing. When I applied the styles, the tabs got removed for some reason that I just can't figure out. 

             

            Screenshot 2017-06-02 12.56.01.pngScreenshot 2017-06-02 12.56.32.pngScreenshot 2017-06-02 12.56.48.pngScreenshot 2017-06-02 12.57.19.pngScreenshot 2017-06-02 13.01.43.png

            • 3. Re: Issue with Table of Contents Formatting
              BarbBinder Adobe Community Professional

              Ok, I can see the hard return characters at the end of the short lines. So you will want to remove those from the source documents and then update the table of contents.

               

              As for the rest of the formatting, you want to have tabs and not spaces following the paragraph numbers. And that should also be happening in the source documents.

               

              Finally, I see that you're creating hanging indents by manually adding spaces. You can do that with your paragraph style. I'm not at my computer right now but I'll be back in about an hour. I'll send an image that shows you how to set it up. If you want to give it a try on your own, the way the correct way to create a hanging indent is to set a left indent that matches the tab position. Then have a  negative 1st line indent that pulls the first line left back towards the margin.

              • 4. Re: Issue with Table of Contents Formatting
                Sheryl Checkman Level 1

                I'm trying to add tabs to the paragraph headings as you suggest. ie 1.1. [Tab] then title but the tab space seems very large even at a '0' measurement. Also when I try to add a tab to my sub heads I am getting a leader line even though there is no leader specified in the tab box. For some reason it is picking up that style from somewhere.

                • 5. Re: Issue with Table of Contents Formatting
                  Sheryl Checkman Level 1

                  I'm getting closer. I inserted tabs in the source document and got rid of the soft returns  which did resolve The TOC 1 (Heads) and TOC2 (Subheads) issue. However, I'm not sure what to do with the TOC3 content that I currently am creating the hanging indents by spaces. When I try to add a tab in place of the space, I get a line of leader dots. How do I get rid of them?? I assume that this is coming from the TOC3 style for between entry and number...

                   

                  Screenshot 2017-06-02 14.42.16.png

                  • 6. Re: Issue with Table of Contents Formatting
                    BarbBinder Adobe Community Professional

                    You are so close!!

                     

                    For the heading 4.1.1, the first tab is too close to the numbers, so the text is moving to the 2nd tab stop.

                    InDesign CCss_016.png

                    Select one of the TOC3s. Choose Type > Tabs. Select the first tab in the tab bar, and increase the distance until the formatting falls back into place. Then right click over TOC3 in the Paragraphs style panel and choose Redefine Style.InDesign CCss_015.png

                    • 7. Re: Issue with Table of Contents Formatting
                      Sheryl Checkman Level 1

                      Thanks that worked. I think I have it all looking right now (see attached).

                      Screenshot 2017-06-02 15.57.27.png

                       

                      Now the problem I have is in the main content. Where I added the tabs, the space is very big between the number and the title. When I tried to adjust the tab and redefine the style it wouldn't work. If I cleared the overrides on them, I lost the balance ragged lines that I had created. Am I still missing something here?

                       

                      Screenshot 2017-06-02 15.52.19.png

                      • 8. Re: Issue with Table of Contents Formatting
                        BarbBinder Adobe Community Professional

                        The TOC looks great!

                         

                        There are two ways to update a style. The easiest for most people is to fix one paragraph, and then redefine the style. Taking that approach:

                        1. Select the 3.1 paragraph
                        2. Type > Tabs, decrease the space for the first (and only tab)
                        3. Type > Paragraph > panel menu > enable Balance Ragged lines
                        4. With that paragraph still selected, right click over SubHeads and select Redefine Style to make all the other SubHeads follow suit.

                         

                        That should do it!

                        • 9. Re: Issue with Table of Contents Formatting
                          Sheryl Checkman Level 1

                          You have been so very helpful. I am doing what you said but am still having an issue. When I redefine the style it seems to work on some but not all and the spacing seems to be not the same throughout. I checked to see if there were any overrides on the ones that aren't behaving but it doesn't look like it. I am also having a problem making the space less on the main heads as well. See attached.

                           

                          Screenshot 2017-06-02 16.33.21.pngScreenshot 2017-06-02 16.37.24.pngScreenshot 2017-06-02 16.42.18.png

                          • 10. Re: Issue with Table of Contents Formatting
                            BarbBinder Adobe Community Professional

                            Can you clarify what you mean by "spacing"? Is it the space after the tab?

                             

                            You are using a font with proportional numbers which means that a 3 is wider than a 1. In addition, for the first time I am seeing a 3 digit number: 3.10. Tabs are a fixed distance from the left margin, so what you are setting is a consistent distance from the left margin on every SubHead to the first letter after the tab. Because of the proportional font and the varying number of digits, the space itself will appear wider or narrower, depending what precedes it.

                             

                            Options are:

                            1. Set the tab stop to accommodate the widest possibility (so far that's 3.10 but 3.33 or 5.25 would be wider still).
                            2. Replace the tabs with a fixed with character like an em or en space. Note that while you may prefer the look of a fixed width space, it will be copied into the TOC and then will cause alignment issues over there.
                            3. Use a fixed with character like an em or an em, and the use Find/Change to replace that character with a tab in the TOC, after all the edits are complete.
                            • 11. Re: Issue with Table of Contents Formatting
                              Sheryl Checkman Level 1

                              Yes I was referring to the space after the tab. Thank you for your suggestions. I'm going cross-eyed right now so I won't try your suggestions till I've take a break but I really appreciate how helpful you have been!