4 Replies Latest reply on Jun 19, 2017 7:41 AM by AngelSaik

    Splash screen not working for IOS

    abell49168673

      I get this in the log

       

      /tmp/gimlet/2647594/project/BlueMoon/Images.xcassets:./AppIcon.appiconset/[][iphone][57x57 ][][][1x]: notice: 57x57 app icons only apply to iPhone apps targeting releases of iOS prior to 7.0

      /tmp/gimlet/2647594/project/BlueMoon/Images.xcassets:./AppIcon.appiconset/[][iphone][57x57 ][][][2x]: notice: 57x57@2x app icons only apply to iPhone apps targeting releases of iOS prior to 7.0

      /tmp/gimlet/2647594/project/BlueMoon/Images.xcassets:./AppIcon.appiconset/[][ipad][50x50][ ][][1x]: notice: 50x50 iPad spotlight icons only apply to iPad apps targeting releases of iOS prior to 7.0

      /tmp/gimlet/2647594/project/BlueMoon/Images.xcassets:./AppIcon.appiconset/[][ipad][50x50][ ][][2x]: notice: 50x50 iPad spotlight icons only apply to iPad apps targeting releases of iOS prior to 7.0

      /tmp/gimlet/2647594/project/BlueMoon/Images.xcassets:./AppIcon.appiconset/[][ipad][72x72][ ][][1x]: notice: 72x72 app icons only apply to iPad apps targeting releases of iOS prior to 7.0

      /tmp/gimlet/2647594/project/BlueMoon/Images.xcassets:./AppIcon.appiconset/[][ipad][72x72][ ][][2x]: notice: 72x72@2x app icons only apply to iPad apps targeting releases of iOS prior to 7.0

      /tmp/gimlet/2647594/project/BlueMoon/Images.xcassets:./LaunchImage.launchimage/[iphone][][ 1x][portrait][full-screen][]: notice: This launch image only applies to iOS 6.x and prior but the minimum deployment is 7.0 or later.

      /tmp/gimlet/2647594/project/BlueMoon/Images.xcassets:./LaunchImage.launchimage/[iphone][][ 2x][portrait][full-screen][]: notice: This launch image only applies to iOS 6.x and prior but the minimum deployment is 7.0 or later.

      /tmp/gimlet/2647594/project/BlueMoon/Images.xcassets:./LaunchImage.launchimage/[iphone][re tina4][2x][portrait][full-screen][]: notice: This launch image only applies to iOS 6.x and prior but the minimum deployment is 7.0 or later.

      /tmp/gimlet/2647594/project/BlueMoon/Images.xcassets:./LaunchImage.launchimage/[ipad][][1x ][portrait][full-screen][]: notice: This launch image only applies to iOS 6.x and prior but the minimum deployment is 7.0 or later.

      /tmp/gimlet/2647594/project/BlueMoon/Images.xcassets:./LaunchImage.launchimage/[ipad][][2x ][portrait][full-screen][]: notice: This launch image only applies to iOS 6.x and prior but the minimum deployment is 7.0 or later.

      /tmp/gimlet/2647594/project/BlueMoon/Images.xcassets:./LaunchImage.launchimage/[iphone][73 6h][3x][portrait][full-screen][8.0]: notice: This launch image only applies to iOS 6.x and prior but the minimum deployment is 7.0 or later.

      /tmp/gimlet/2647594/project/BlueMoon/Images.xcassets:./LaunchImage.launchimage/[iphone][73 6h][3x][landscape][full-screen][8.0]: notice: This launch image only applies to iOS 6.x and prior but the minimum deployment is 7.0 or later.

      /tmp/gimlet/2647594/project/BlueMoon/Images.xcassets:./LaunchImage.launchimage/[iphone][66 7h][2x][portrait][full-screen][8.0]: notice: This launch image only applies to iOS 6.x and prior but the minimum deployment is 7.0 or later.

       

      After the build, my splash images are not in the .ipa archive.

       

      Here's my config.xml

       

       

      <platform name="ios">

              <allow-intent href="itms:*" />

              <allow-intent href="itms-apps:*" />

              <preference name="BackupWebStorage" value="local" />

              <icon src="res/icon/icon180.png" width="180" height="180" />

              <icon src="res/icon/icon60.png" width="60" height="60" />

              <icon src="res/icon/icon120.png" width="120" height="120" />

              <icon src="res/icon/icon76.png" width="76" height="76" />

              <icon src="res/icon/icon152.png" width="152" height="152" />

              <icon src="res/icon/icon40.png" width="40" height="40" />

              <icon src="res/icon/icon80.png" width="80" height="80" />

              <icon src="res/icon/icon57.png" width="57" height="57" />

              <icon src="res/icon/icon114.png" width="114" height="114" />

              <icon src="res/icon/icon72.png" width="72" height="72" />

              <icon src="res/icon/icon144.png" width="144" height="144" />

              <icon src="res/icon/icon29.png" width="29" height="29" />

              <icon src="res/icon/icon58.png" width="58" height="58" />

              <icon src="res/icon/icon50.png" width="50" height="50" />

              <icon src="res/icon/icon100.png" width="100" height="100" />

              <splash src="res/splash/splash320x480.png" width="320" height="480"/>

              <splash src="res/splash/splash640x960.png" width="640" height="960"/>

              <splash src="res/splash/splash768x1024.png" width="768" height="1024"/>

              <splash src="res/splash/splash1536x2048.png" width="1536" height="2048"/>

              <splash src="res/splash/splash1024x768.png" width="1024" height="768"/>

              <splash src="res/splash/splash2048x1536.png" width="2048" height="1536"/>

              <splash src="res/splash/splash640x1136.png" width="640" height="1136"/>

              <splash src="res/splash/splash750x1334.png" width="750" height="1334"/>

              <splash src="res/splash/splash1242x2208.png" width="1242" height="2208"/>

              <splash src="res/splash/splash2208x1242.png" width="2208" height="1242"/>

          </platform>

       

       

      Anyone help?

        • 1. Re: Splash screen not working for IOS
          vangroover Adobe Employee

          did you resolve your issue, as i can see the splashes and icons are in your ipa?

          • 2. Re: Splash screen not working for IOS
            AngelSaik

            I have the same question. I used to build my ios app using Myeclipse and the splash screen appears successfully. when I updated to Version: 2015 CI 19 and update all the deprecated plugin-ins, only the default splash screen appears. here's the related config.xml. how can I solve this problem.

            <content src="Main.html"/>

              <name>VTE</name>

              <!-- Uncomment and edit to specify a specific phonegap version

              otherwise use PhoneGap Build will use the most recent version

              -->

              <!-- <preference name="phonegap-version" value="3.5.0"/> -->

             

             

              <preference name="StatusBarOverlaysWebView" value="false" />

              <preference name="StatusBarBackgroundColor" value="black" />

              <preference name="StatusBarStyle" value="lightcontent" />

              <!-- <preference name="ios-statusbarstyle" value="black-opaque"/> -->

             

             

              <!-- For a descripton of preferences see

              http://docs.build.phonegap.com/en_US/configuring_preferences.md.html#Preferences

              -->

              <preference name="permissions" value="none" />

              <preference name="orientation" value="default" />

              <preference name="target-device" value="universal" />

              <preference name="fullscreen" value="true" />

              <!-- set false to show android statusbar -->

              <preference name="webviewbounce" value="true" />

              <preference name="prerendered-icon" value="true" />

              <preference name="stay-in-webview" value="false" />

              <preference name="detect-data-types" value="true" />

              <preference name="exit-on-suspend" value="false" />

             

              <plugin name="cordova-plugin-splashscreen" source="npm" />

             

              <preference name="show-splash-screen-spinner" value="false" />

              <preference name="FadeSplashScreen" value="true" />

              <preference name="FadeSplashScreenDuration" value="1.0" />

              <preference name="SplashScreen" value="splash" />

              <preference name="SplashScreenDelay" value="5000" />

              <preference name="auto-hide-splash-screen" value="false" />

              <preference name="disable-cursor" value="false" />

              <preference name="android-minSdkVersion" value="7" />

              <preference name="android-installLocation" value="auto" />

             

             

            <!-- Core cordova/phonegap plugins -->

              <plugin name="cordova-plugin-email-composer" spec="0.8.3" source="npm" />

             

              <plugin name="cordova-plugin-battery-status" spec="~1.2.2" />

              <plugin name="cordova-plugin-camera" spec="~2.3.1" />

              <plugin name="cordova-plugin-console" spec="~1.0.5" />

              <plugin name="cordova-plugin-contacts" spec="~2.2.1" />

              <plugin name="cordova-plugin-device" spec="~1.1.4" />

              <plugin name="cordova-plugin-device-motion" spec="~1.2.3" />

              <plugin name="cordova-plugin-device-orientation" spec="~1.0.5" />

              <plugin name="cordova-plugin-dialogs" spec="~1.3.1" />

              <plugin name="cordova-plugin-file" spec="~4.3.1" />

              <plugin name="cordova-plugin-file-transfer" spec="~1.6.1" />

              <plugin name="cordova-plugin-geolocation" spec="~2.4.1" />

              <plugin name="cordova-plugin-globalization" spec="~1.0.5" />

              <plugin name="cordova-plugin-inappbrowser" spec="~1.6.1" />

              <plugin name="cordova-plugin-media" spec="~2.4.1" />

              <plugin name="cordova-plugin-media-capture" spec="~1.4.1" />

              <plugin name="cordova-plugin-network-information" spec="~1.3.1" />

             

              <plugin name="cordova-plugin-vibration" spec="~2.1.3" />

              <plugin name="cordova-plugin-statusbar" spec="~2.2.1" />

              <plugin name="cordova-plugin-whitelist" spec="~1.3.1" />

             

             

             

              <!-- MobiOne plugins  -->

             

              <!-- 

              <plugin name="com.genuitec.mobione.phoneui" spec="0.2.7"

              source="npm"/>

             

              <plugin name="org.apache.cordova.vibration" spec="0.3.13"

              source="pgb" />

             

              <plugin name="com.phonegap.plugins.childbrowser" spec="5.0.0"

              source="pgb" />

              <plugin name="de.appplant.cordova.plugin.printer" source="pgb"

              version="0.7.1">

              </plugin>

              <plugin name="cordova-plugin-splashscreen" spec="~4.0.1" />

              -->

             

             

             

             

              <!-- Default app icon appearing on device homescreen -->

             

             

              <!-- Android app branding artwork -->

              <spalsh platform="android" qualifier="port-ldpi"

              src="branding/screen/android/screen-ldpi-portrait.png" />

              <spalsh platform="android" qualifier="port-mdpi"

              src="branding/screen/android/screen-mdpi-portrait.png" />

              <spalsh platform="android" qualifier="port-hdpi"

              src="branding/screen/android/screen-hdpi-portrait.png" />

              <spalsh platform="android" qualifier="port-xhdpi"

              src="branding/screen/android/screen-xhdpi-portrait.png" />

             

             

             

             

             

             

             

              <!-- Whitelist of urls this app may open in an InAppBrowser -->

              <access origin="*" />

             

             

              <!-- Configure remote debugging on Android 4.4 & greater.                     -->

              <!--  Overrides MyEclipse Build dialog's debug mode.                          -->

              <!-- Set android:debuggable="true" to enable remote debugging.                -->

              <!-- Set android:debuggable="false" or remove element for production release. -->

              <!--

              <config-file parent="/manifest" platform="android">

              <application android:debuggable="false"/>

              </config-file>

              -->

             

             

              <!-- iOS app branding artwork -->

             

              <platform name="ios" />

              <!-- iOS 8.0+ -->

              <!-- iPhone 6 Plus  -->

              <icon src="icon.png" />

              <icon platform="ios" width="144" height="144"

              src="branding/icon/ios/icon-72-2x.png" />

              <icon src="branding/icon/ios/icon-180.png" width="180" height="180" />

              <icon height="120" platform="ios" width="120"

              src="branding/icon/ios/icon-60-2x.png" />

              <icon height="114" platform="ios" width="114"

              src="branding/icon/ios/icon-57-2x.png" />

              <icon height="512" platform="ios" width="512"

              src="branding/icon/ios/icon512.png" />

              <icon height="152" platform="ios" width="152"

              src="branding/icon/ios/icon152.png" />

              <icon height="60" platform="ios" width="60"

              src="branding/icon/ios/icon-60.png" />

              <icon height="57" platform="ios" width="57"

              src="branding/icon/ios/icon-57.png" />

              <icon height="72" platform="ios" width="72"

              src="branding/icon/ios/icon-72.png" />

              <icon height="76" platform="ios" width="76" src="branding/icon/ios/icon-76.png"/>

             

             

              <spalsh src="splash.png" />

              <spalsh height="1136" platform="ios" width="640"

              src="branding/screen/ios/spalsh_640x1136.png" />

              <spalsh height="768" platform="ios" width="1024"

              src="branding/screen/ios/splash_1024x768.png" />

              <spalsh height="960" platform="ios" width="640"

              src="branding/screen/ios/splash_640x960.png" />

              <spalsh height="480" platform="ios" width="320"

              src="branding/screen/ios/splash_320x480.png" />

              <spalsh height="1024" platform="ios" width="768"

              src="branding/screen/ios/splash_768x1024.png" />

              <spalsh height="2048" platform="ios" width="1536"

              src="branding/screen/ios/splash_1536x2048.png" />

              <spalsh height="1536" platform="ios" width="2048"

              src="branding/screen/ios/splash_2048x1536.png" />

              <spalsh height="640" platform="ios" width="1136"

              src="branding/screen/ios/spalsh_1136x640.png" />

              <spalsh height="2208" platform="ios" width="1242"

              src="branding/screen/ios/spalsh_1242x2208.png" />

              <spalsh height="1242" platform="ios" width="2208"

              src="branding/screen/ios/spalsh_2208x1242.png" />

              <spalsh height="1134" platform="ios" width="750"

              src="branding/screen/ios/spalsh_750x1334.png" />

              <spalsh height="750" platform="ios" width="1134"

              src="branding/screen/ios/spalsh_1334x750.png" />

              <spalsh height="2732" platform="ios" width="2048"

              src="branding/screen/ios/spalsh_2048x2732.png" />

              <spalsh height="2048" platform="ios" width="2732"

              src="branding/screen/ios/spalsh_2732x2048.png" />

             

             

             

             

             

             

             

            </widget>

            • 3. Re: Splash screen not working for IOS
              vangroover Adobe Employee

              your config.xml says "spalsh" where it should be "splash"

              • 4. Re: Splash screen not working for IOS
                AngelSaik Level 1

                you're right. thanks

                I used:

                <preference name="phonegap-version"           value="cli-5.4.1" />

                to make it work. I can see the splash screen now but its in the middle of the screen (vertically: with a black background on top and bottom, while horizontally: at the right and left ). the app is not full screen