17 Replies Latest reply on Jun 8, 2017 11:28 AM by Michael Thornburgh

    Adobe Stratus

    robm24784149

      Hello,

       

      I am having problems when I try to use webcam based websites such as Omegle.  I get an error that states - "Error connecting to Adobe Stratus."  I have tried googling the solution and browsing the forum for this problem but no luck. 

       

      Anyone know why this happens?

       

       

      Thanks.

        • 1. Re: Adobe Stratus
          robm24784149 Level 1

          Any help here? :/

          • 2. Re: Adobe Stratus
            divya_1993 Adobe Employee

            Before posting, please read and provide the following information:

            • 4. Re: Adobe Stratus
              Michael Thornburgh Adobe Employee

              i am not seeing any problems connecting to the Cirrus (codename) service (i just tried from my own test app).  my logs indicate plenty of users connecting, connected, and performing P2P lookups.  i see no indications of service interruptions or problems in my logs and graphs.

               

              what happens if you go to http://cc.rtmfp.net ? if you are able to connect to CC, then perhaps there is a problem with the application(s) you're trying to use.  i'd suggest contacting whoever operates the service(s) you're trying to use.

               

              is Flash Player enabled in your web browser?  are you using the most recent version of Flash?  some browsers disable Flash if you're not up-to-date.

               

              if you're not able to connect to CC but the page loads and runs in Flash Player, then perhaps you have an IPv4 UDP connectivity problem to the outside world.

               

              Cirrus listens on IPv4 only.  if you are on an IPv6-only network or are behind certain IPv6 translators (like NAT64), you might not be able to connect to Cirrus even though you can connect to CC (because Cirrus is behind an RTMFP load balancer and CC is not).

              • 5. Re: Adobe Stratus
                robm24784149 Level 1

                When I go to http://cc.rtmfp.net it stays connecting then says failed to connect.

                Flash player is enabled in my web-browser and it is the most recent.

                 

                I am using a 2015 Macbook Pro, others using such sites like Omegle using the same wifi are able to have it work.  However, I get the "error connecting to adobe stratus"

                • 6. Re: Adobe Stratus
                  Michael Thornburgh Adobe Employee

                  are you using a VPN?  do you have a firewall enabled?  what web browser are you using? what happens when you try a different web browser?

                   

                  since it's working for other folks on your network, that suggests it's something specific to your computer. have you tried turning it off and on again?

                  • 7. Re: Adobe Stratus
                    robm24784149 Level 1

                    I am not using a VPN - I have tried to see if it would help but nope

                    I have tried enabling/disabling the firewall

                    I've used Chrome, Firefox, Safari (all recent updates)

                     

                    I have indeed tried turning it off and on again.

                    • 8. Re: Adobe Stratus
                      Michael Thornburgh Adobe Employee

                      at this point the easiest thing to try would be a packet dump.

                       

                      first find the interface name for your internet connection.  it's most likely "en1" or possibly "en0" (i don't know if the 2015 macbook pro has a built-in ethernet, so depending your wifi will probably be either en1 or en0).  in a terminal window, say "netstat -rn" and look for the entry that says "default".  the "Netif" column is the interface.  then, assuming it's "en1", in your terminal window, say

                       

                      sudo tcpdump -n -i en1 udp port 1935

                       

                      and while that's running, try connecting to cc.rtmfp.net.  ideally you would see a flurry of packets between your computer and cc.rtmfp.net (198.61.227.125).  if you see only outgoing packets that look like

                       

                      21:05:30.943857 IP 10.0.1.2.50174 > 198.61.227.125.1935: UDP, length 52

                      21:05:31.943857 IP 10.0.1.2.50174 > 198.61.227.125.1935: UDP, length 52

                      ...

                       

                      with no answers from 198.61.227.125, then your packets aren't making it out but are being sent.  if you see nothing at all, then either you didn't get the right interface name or Flash Player is somehow not sending packets at all.

                       

                      if you see some packets in each direction but the connection still isn't completing, it would be helpful for you to paste in exactly what your tcpdump is saying.

                      • 9. Re: Adobe Stratus
                        robm24784149 Level 1

                        Ok, so I did sudo tcpdump           -n -i en0 udp port 1935

                        I used en0 cause that's what it had with mine on default.

                         

                        My tcpdump is saying (first few lines):

                         

                         

                        tcpdump: verbose output suppressed, use -v or -vv for full protocol decode

                        listening on en0, link-type EN10MB (Ethernet), capture size 262144 bytes

                        21:31:54.188336 IP 172.31.8.254.58092 > 198.61.227.125.1935: UDP, length 52

                        21:32:04.688871 IP 172.31.8.254.58092 > 198.61.227.125.1935: UDP, length 52

                        21:32:16.691743 IP 172.31.8.254.58092 > 198.61.227.125.1935: UDP, length 52

                         

                        I went to cc.rtmfp.net and it still failed to connect.

                        • 10. Re: Adobe Stratus
                          Michael Thornburgh Adobe Employee

                          that packet dump shows:

                           

                            * loading the web page indicates you can reach the server, so bidirectional routing of TCP is working

                            * your computer is sending UDP packets out (from a NAT address), so Flash and RTMFP are working

                            * no replies are coming back to you

                            * the CC server is responding to others, so it is working

                            * others using the same wifi aren't having a problem

                           

                          these data points suggest that your NAT is treating UDP packets from your computer differently than those from other computers on the same network.  therefore: 1) are you absolutely sure that the people for whom it is working are using exactly the same wifi network/access point that you are?  and 2) have you tried turning the access point off and on again?

                           

                          could the network/access point have a special configuration unique to your computer that might block UDP access for you but allow it for others?  for example, is this an access point operated by someone else, where you need to log in or pay or something for "full" access?

                           

                          have you tried accessing from a different network?  if you get the same result on a different network but it's working for other people, that suggests a problem on your computer.

                          • 11. Re: Adobe Stratus
                            robm24784149 Level 1

                            Yup, other people are using the same school Wifi. 

                            I'm not sure about access points?

                             

                            Not sure how to go on with this.  The website doesn't work -  it still fails to connect.

                            I actually can't even put the router's number into the address box in any of my browsers and have it load.

                            • 12. Re: Adobe Stratus
                              Michael Thornburgh Adobe Employee

                              the next thing to try is to attempt to connect from a different network (that is, not your school network).

                               

                              if you can't connect from a totally different network, it is probably your computer.

                               

                              if you can connect from a totally different network, it is probably your school network.  check with the network administrator.