10 Replies Latest reply on Jun 20, 2017 9:25 AM by YogitaBist

    Flicker Problem

    chungk67205631

      Hello,

       

      I have been experiencing a flicker on the very first load (cache, cookies cleared).  We are using mbox.js Version 62. To try to remedy this issue, I’ve tested this in two ways:

       

      1. Using the Visual Composer to make the edits:
      • - Flicker is still there on the _very first_ load, and seems to work on subsequent visits.

       

      1. Using vanilla javascript to immediately inject a style with visibility: hidden through the custom code section (in the head).  Then show it (visibility: visible) after the content loads.
      • - Flicker is still there on the _very first_ load, but works on subsequent visits

       

      In the previous release notes it stated that:

       

      Mbox Version 61 (16.7.2)

      • Body hiding is disabled by default. Target uses body hiding only when global mbox auto-create is enabled and body hiding is enabled.

       

      And

       

      Mbox Version 60 (16.4.1)

                        window.targetGlobalSettings = {

                           bodyHidingEnabled: true,

                           bodyHiddenStyle: "body{opacity:0}",

                           visitorPageDisplayTimeout: 2000

                      };

       

       

      Would anyone know if Is this a setting that we could implement?

       

      The release notes also stated that:

       

      New Visitor scenarios might have flicker”

      When using v58 to v60 with the visitor id service, mbox calls will wait for the visitor id to be set before firing (or until a timeout has occurred). This happens on the first page load of a new visitor.

       

      Which also suggests that it is a limitation on all first visitors?

       

      Would it be possible to get clarification on this issue?  Specifically whether there is a setting we can set (with mbox.js 62), or will there always be that flicker on the first page visit?

       

      Thank you,

      Chung