1 Reply Latest reply on Jun 7, 2017 1:48 PM by John Waller

    which adobe photoshop lightroom is compatible for my mac os x 10.9.5

    patrickg55298308

      I have a Mac OSX 10.9.5 and I would like to upgrade my Lightroom 4 to the latest version, like Lightroom 6 , is it possible..