9 Replies Latest reply on Jun 8, 2017 12:19 PM by Jim Wilde

    Photos not importing from camera

    emilyarau Level 1

      Hi there. I am trying to import my images from my camera straight to LR like I have done a million times (most recent being 3 days ago). Today when I try to import, it lets me select my import device, however at the bottom right it says 0 photos/0 bytes along with a spinning wheel. I thought maybe it was just taking awhile to read but I have given it multiple attempts of 30 and 60 minutes with no avail. I was originally trying to import from my Canon 6D, but when that wasn't working, I tried using my Canon t3i, which also did not work. I tried switching out the usb cable that connects to my camera and that also made no difference. It seems like I can import them straight to my computer, so it doesn't seem like its the camera/memory card/cable at fault, but I would not prefer to use this method as it is very inefficient. I would like to be able to import my clients images straight to LR like I always have done in the past. Has this happened to anyone before or do you have any  advice on what I can do to fix the problem?? Thank you.