1 Reply Latest reply on Jun 13, 2017 12:56 PM by vangroover

    Target iOS SDK 10.3

    WeaponX86 Level 1

      I am trying to build our app and target the 10.3 SDK. This is not working on PGB and is throwing some warnings in the log.

       

      Here is the first part of the log that states 10.3 can't be used.

       

      Build settings from configuration file '/private/tmp/gimlet/1887579/project/cordova/build-release.xcconfig':
          ARCHS = armv7 arm64
          CLANG_ALLOW_NON_MODULAR_INCLUDES_IN_FRAMEWORK_MODULES = YES
          CODE_SIGN_ENTITLEMENTS = /tmp/gimlet/1887579/project/app.entitlements
          CODE_SIGN_IDENTITY = iPhone Developer
          CONFIGURATION_BUILD_DIR = /tmp/gimlet/1887579/project/build
          CORDOVALIB = /tmp/gimlet/1887579/project/CordovaLib
          DEVELOPMENT_TEAM = *****REMOVED*****
          ENABLE_BITCODE = false
          HEADER_SEARCH_PATHS = "$(TARGET_BUILD_DIR)/usr/local/lib/include" "$(OBJROOT)/UninstalledProducts/include" "$(OBJROOT)/UninstalledProducts/$(PLATFORM_NAME)/include" "$(BUILT_PRODUCTS_DIR)"
          IPHONEOS_DEPLOYMENT_TARGET = 10.3
          ONLY_ACTIVE_ARCH = NO
          OTHER_CODE_SIGN_FLAGS = --keychain /tmp/gimlet/1887579/secure.keychain
          OTHER_LDFLAGS = -ObjC
          PROVISIONING_PROFILE = *****REMOVED*****
          SWIFT_OBJC_BRIDGING_HEADER = $(PROJECT_DIR)/$(PROJECT_NAME)/Bridging-Header.h
          TARGETED_DEVICE_FAMILY = 1,2
      
      === BUILD TARGET CordovaLib OF PROJECT CordovaLib WITH CONFIGURATION Release ===
      
      Check dependencies
      iOS deployment target '10.3' for architecture 'arm64' and variant 'normal' is greater than the maximum value '10.1.99' for the iOS 10.1 SDK.
      

       

      I have built the app locally use phonegap cli and it compiles fine when I target 10.3. Does PGB support 10.3? Is this not the cause of the error and just confusing me?

       

      Any help would be appreciated.

       

      Thank you