1 Reply Latest reply on Jun 13, 2017 5:03 PM by alexeit20270339

    LR Mobile sync photo count mismatch

    alexeit20270339

      I created a large mobile sync collection, let's say, with 1300 photos. I opened the LR app on iPad and watched the collection first appear and then get populated with photos. It eventually synced. I did not check the count. I also clicked Make available offline, and overtime the photos loaded on the iPad. In the meantime, I continued paring down the collection on the desktop in two ways:

       

      1) I would be in the library folder and perhaps mark a photo that had been added to the synced collection as Rejected, and then delete rejected photos.

      2) I would hit B key (I had made my synced collection the target) to remove a photo from the synced collection without deleting it.

       

      I expect either action would remove a photo from the synced collection. When the dust settled and I was satisfied with the contents of the collection on the desktop, I compared the counts. Desktop reads 1127. iPad reads 1138.

       

      I have tried the following to bring the numbers in sync:

       

      - Restarted LR on desktop

      - Restarted LR on iPad

      - Paused and unpause mobile syncing in LR on desktop

      - Took out another photo from the synced collection by hitting B (no effect on iPad)

      - Edited metadata of a photo in the synced collection (did not see the "Syncing 1 photo" status message in top left corner)

      - Added three random photos I did not need in the collection (saw the "Syncing 3 photos" in top left, the count on iPad went up by 3) and removed them (the count went back down by 3)

       

      I see some of the photos that are still showing on the iPad and have been removed from the desktop collection: they are the ones I hit B on. But I cannot reliably identify all 11 discrepancies, or explain why it happened, or force the two collections to sync.

       

      Now comes the crazy part.

       

      I right-clicked the synced collection on desktop and said Duplicate...

       

      It duplicated (I also made it sync to mobile), it has the same 1127 photos.

       

      It showed up in fits and starts. It would say 492 photos for a longish time... then after some time 592... then 692.... then it went up faster and settled at... 1116.

       

      Not 1138 and not 1127, but 1116. A seemingly random number.

       

      I did this twice (deleted the duplicated collection and duplicated the master collection, the one with 1127 photos) and again got 1116 when the numbers on iPad stopped climbing.

       

      What gives? What can explain this behavior and how can I force a collection to re-sync? I considered marking it as not synced. Presumably it will delete all photos from the cloud. And then marking it as synced again. But I am reluctant to do this without really understanding the issue for two reasons: one, it takes a while for 1127 (or 1116 or 1138) photos to get synced up to the cloud and another while for them to come down to iPad for offline editing, and two, there is no guarantee that it will help -- see the experiment with the duplicated collection coming up with a random number of photos.

       

      I viewed the synced collections on the lightroom.adobe.com, but I can't find the count to compare whether it matches desktop, iPad or neither. Can you tell me where the collection photo count is on the web?

       

      Thanks!

        • 1. Re: LR Mobile sync photo count mismatch
          alexeit20270339 Level 1

          Guess I can't edit it anymore after a while. Here is an update.

           

          I did find how to see the number of photos in a collection on the web. Once you click on a photo, it says < 3 of 1149 >

           

          And so there are now some additional data points.

           

          Original collection:

          Desktop 1127

          iPod/iPhone 1138 (11 more than desktop)

          Web 1149 (11 more than iOS)

           

          Duplicated collection:

          Desktop 1127

          iPod/iPhone 1116 (11 fewer than desktop)

          Web 1127 (same as desktop, finally)!

           

          What is with the magic number 11?

           

          BYW, if you are going to suggest I deleted Sync.lrdata, I am aware of that. I had to do it before when sync stopped working altogether. I am not crazy about this option and I still want to understand why this is happening. An answer "because there is a bug in Lightroom (perhaps Lightroom iOS app) from Adobe will be acceptable. But I hope this bug is understood and is being worked on.