4 Replies Latest reply on Nov 28, 2017 10:51 AM by danc11931235

    "Offset" effect messes up with gpu rendering is enabled in AE CC

    darrikb

      Long story short, I created an animation preset (.ffx) in AE CS6 that includes the effects: Transform, Motion Tile, Offset, and some sliders with expressions.

      And I sell this preset online to AE CS6 and CC users. Everything has been fine until recently when Adobe had an update for CC (around April I think) that enabled gpu rendering. My buyers who use CC have told me that when gpu rendering is used, it messes up the "offset" effect (see example below), but it looks fine when gpu rendering is disabled. Has this happened to anyone else? I really dont think it's an issue with my preset because it works just fine otherwise.

       

       

       

       

      19074551_10203404273143251_1511581862_o.png

       

        • 1. Re: "Offset" effect messes up with gpu rendering is enabled in AE CC
          Szalam Adobe Community Professional & MVP

          What is it supposed to look like? What GPU rendering are they turning on and off? Does it happen on both Macs and PCs? Does it happen on CUDA, OpenCL, or Metal or all or both?

           

          Don't forget, you can download a trial of CC 2017 and try it out for yourself and maybe make a version that works with GPU-acceleration.

          • 2. Re: "Offset" effect messes up with gpu rendering is enabled in AE CC
            darrikb Level 1

            It's suppose to look like a plain, normal image without the tiling/offset in the middle.

            In the Project Settings, there's an option for gpu rendering or software rendering. Switching back and forth changes what the preview looks like, even though the values of the offset effect aren't changing.

             

            I'm not sure about mac or pc, but from a few comments I've seen, I think it's mostly happening on PCs.

            Not sure about CUDA, OpenCL, or Metal either.

             

            Point is, whether its Mac or PC, the preset is just a combination of effects and should work the same.

            With GPU rendering on or off, the same values in the offset effect should give you the same result, but it doesnt for some reason.

            Doesn't make sense to me.

            • 3. Re: "Offset" effect messes up with gpu rendering is enabled in AE CC
              Kevin-Monahan Adobe Employee

              Hi darrikb,

              Are you still facing this problem? If not, let us know how you solved it. If so, please let us know so we can assist you further.

               

              Thanks,

              Kevin

              • 4. Re: "Offset" effect messes up with gpu rendering is enabled in AE CC
                danc11931235

                Hi everyone,

                 

                I have the same issue.

                I updgraded after effects cc2018 last week and I noticed that the transform effect has offset issues when GPU rendering is on !!

                cpu on.jpg

                Example :

                i have a composition that contains a footage and

                an adjustment layer above with the transform effect :

                110% in scale

                and 2 keyframes in position to slide the footage

                 

                 

                so the effect is working well when GPU rendering is off.

                cpu off.jpg

                 

                My PC :

                CPU : AMD Ryzen 7 1700X

                GPU : GeForce GTX 1080 Ti

                memory : 32Go

                OS : Windows 10

                 

                in advance thank you for your answer !

                Dan