4 Replies Latest reply on Jun 17, 2017 12:52 PM by Barbara Ash

    Which InDesign settings give the fastest GUI interaction?

    Gerben Wierda Level 1

      I'm working on a document of >200 pages with >300 diagrams and a lot of references from text to labels on those diagrams, section headings and so forth.

       

      I'm experiencing a lot of type lag, a bit depending on where I am editing. Often, I type and find out that not all the characters actually end up in the document. What can I do to improve the 'snappyness' of InDesign? I've noticed that working in Story Mode is generally fast, but I often need to see what is going on (e.g., on a reference to a diagram, choose to display page number yes or no depending on the fact if the diagram is on the same page yes or no). I also often have text refer to the diagrams, so I must be able to read the diagrams while typing the text.

       

      So, I was wondering how I can make InDesign faster by changing settings.

        • 1. Re: Which InDesign settings give the fastest GUI interaction?
          Derek Cross Level 6

          Which version of InDesign and OS?

          (You mean Story Editor presumably).

          • 2. Re: Which InDesign settings give the fastest GUI interaction?
            Barbara Ash Adobe Community Professional

            There are a few things you can try.

            • Consider adding more RAM to your computer.
            • Under the View > Display Performance, choose Typical. (Choosing Fast will speed things further, but your images will look like gray boxes.)
            • Turn off Preflight. Click the down arrow next to the red or green dot and choose Preflight Panel. Then furn off the On checkbox in the panel.
            • Cross references can slow things down, but not much you can do about that. If you have cross references that refer to other InDesign documents, leaving all those documents open will help.
            • In Preferences, in the Interactive pane, set Live Screen Drawing to Delayed.
            • As a last resort, you could reset preferences. Set preferences in Adobe InDesign scroll down to Restore All Preferences and Default Settings.
            • Make sure that there are no missing fonts.
            • File > Save As, and choose IDML. Close your file and open the IDML file.
            • Link your graphics instead of embedding them.
            • If you have hyperlinks, close the Hyperlinks panel so that it isn't updating.
            2 people found this helpful
            • 3. Re: Which InDesign settings give the fastest GUI interaction?
              Gerben Wierda Level 1

              https://forums.adobe.com/people/Barbara+Ash  wrote

               

              There are a few things you can try.

              • Turn off Preflight. Click the down arrow next to the red or green dot and choose Preflight Panel. Then furn off the On checkbox in the panel.

               

              What does preflight do? I think check correctness, right? Should I then do this by hand now and then?

               

              • Make sure that there are no missing fonts.

               

              I don't think there are any, but how do I check?

               

               

               

              • File > Save As, and choose IDML. Close your file and open the IDML file.

               

              What will I lose if I go through this route? There is a lot of work in this document on layout, so losing that is not an option.

               

              • Link your graphics instead of embedding them.

               

              I think my graphics are linked already. They are visible in the document, but when I change them in the folder that they live, ID detects this and asks me if I want to update what is in the document. I have no idea what 'embed' versus 'linked' exactly is.

              • 4. Re: Which InDesign settings give the fastest GUI interaction?
                Barbara Ash Adobe Community Professional

                Preflight is constantly checking for certain common problems like missing fonts, overset text, graphics that are not up to date. Rather than doing it by hand, turn Preflight back on whenever you want to check for correctness. But leave it off most of the time while you are working so that it won't slow down InDesign while you are working.

                 

                When you open a file, InDesign will warn if there are missing fonts. To check for missing fonts, after the file is open, choose Type > FInd Font. If there are missing fonts they will be flagged in the list.

                 

                You won't lose anything by saving as IDML. Sometimes doing that will speed things up after you re-open it. To reassure yourself, you could save the IDML file with a new name.

                 

                From your description, it sounds like all of your graphics are linked. Linked files are referenced by InDesign, kind of like a shortcut on Windows or an Alias on Mac. With embedded files, the whole file is embedded in InDesign and adds to the InDesign file size. InDesign cannot detect when an embedded file is changed and cannot automatically update it.

                 

                InDesign tends to be slow in general, especially with longer documents like the one you're working on. Without seeing your document, I would not be able to say which of the suggestions might help, so I was just throwing out various ideas. But from what you've described, it sounds like adding more RAM to your computer and turning off preflight (temporarily) would help the most.

                 

                When you work in Story Editor, it is a separate window. You could move Story Editor so that you can see both the story editor window and your document window.

                 

                I hope that at least one of these suggestions will help speed up InDesign for you.

                1 person found this helpful