0 Replies Latest reply on Jun 20, 2017 11:41 AM by garya77044957

    Device Authorization

    garya77044957

      Hello all,

           Over the past while I have been dealing with some ever growing frustrations with Digital Editions. I try to copy a book onto my Kobo E-reader and once it is downloaded onto the reader I get a message saying the device isn't authorized. On the computer digital editions shows that both the computer and the Kobo are authorized. On the Kobo itself it also shows that it is authorized. I have contacted many sources of support and end up being told to "de-authorized and reauthorize" my account to fix the problem. For a couple of months that solved the problem and then it would happen again. I have continued to do that until it no longer solved the problem. Now I am having to completely uninstall my Digital Editions and re-install it for it to wok. Previously I was running 4.5.5 (latest version) until today when I I took another piece of advice and installed 3.0.

         Has anyone else had this problem and found a solution? This is becoming a very annoying process to constantly repeat.