6 Replies Latest reply on Jun 21, 2017 10:51 AM by sas21896048

    Lightroom Catalog Won't Optimize - Corrupted?

    sas21896048

      Hi,

       

      I'm using Lightroom 4. I haven't backed up my LR in a few months (yes, I know). I'm trying to back up and I get the following error message:

       

      "Lightroom was unable to back up the catalog named ___. Please check your folder permissions, and make sure that you have available space on your backup drive."

       

      I have tons of space free on all my HDs. I also check all my folder permissions, and that's not the problem.

       

      If I try to run a backup and don't click optimize and don't click check integrity, it WILL successfully complete the backup.

       

      If I try to optimize the catalog, it doesn't seem to do anything. I go to File > Optimize and click Optimize. It says "Optimizing Catalog... This may take several minutes." Then it says "Your catalog was not optimized and Lightroom must restart. Lightroom will check the catalog for damage when it resumes." I click OK. Lightroom restarts. A window comes up quickly and says "Now checking the integrity of __________." And then Lightroom opens as normal.

       

      The catalog doesn't become optimized (the date in Preferences > Catalog Settings remains the same). It also never gives me an error message that the optimization failed, or that the catalog is corrupt.

       

      I can carry on and use LR as normal with my catalog, but I'm very concerned that I'm working on a corrupt catalog.

       

      I also tried the "SQL" trick I read about on these forums using sqlite3. It took my .lrcat file down from 980MB to 968MB which isn't major. I tried getting the new catalog to backup or optimize, and nothing has changed.

       

      Your help is very much appreciated. Thank you.