4 Replies Latest reply on Aug 7, 2017 9:21 PM by bhousto90

    Shift + resize not constraining proportions whilst using smart guides?


      Hi, I'm running indesign CC, and can see from the forums that this is a common problem. My issue is when I resize elements, I always hold shift, and in EVERY Adobe product this constrains the proportions. It now sporadically DOESN'T work in Adobe Indesign. For instance, resizing an icon, or a circle, or a rectangle.


      I have experimented, and I believe that it is only a problem when I am using smart guides. Its like the smart guides desire to snap to guides, etc, is over-riding the shift command to constrain proportions? Its really strange, and I CANNOT find a solution.



      FYI, this happens maybe 40% of the time. 60% of the time - the shift command appears to constrain all proportions correctly. Does anyone know of a fix for this?



        • 1. Re: Shift + resize not constraining proportions whilst using smart guides?
          Steve Werner Adobe Community Professional & MVP

          Version of InDesign? Operating system?


          I use that feature quite a bit in InDesign CC 2017.1 and 2017.0 on a Macintosh. I don't recall it ever not working. And I usually leave Smart Guides turned on.


          It's a known fact that some third-party software interfere with InDesign modifier keys (Shift, Option/Alt sometimes). Sometimes it's a browser plug-in. It usually takes a little experimentation to find out which one. Various Chrome plug-ins, for example.


          The way to test is to reboot the computer and launch InDesign first before any other application is loaded. Then watch as you load other applications to see when the problem starts.

          • 2. Re: Shift + resize not constraining proportions whilst using smart guides?
            bhousto90 Level 4

            I believe I am having the same inconsistent problems with the Shift key as you are but I have found out the following while resizing images placed within a object frame:


            While holding the keyboard Shift key down if you let the mouse pointer drift away from the corner handle while resizing, then when you release the mouse button it will inconsistently either take the correct proportional resize (as shown by the resizing handles/lines) or it will instead resize the image to where the mouse pointer physically was when button is released.

            However, if I use one of the hotkeys on my Wacom Intous 5 tablet instead as the Shift key then the proportional resizing is done correctly irregardless if the mouse pointer drifts from the corner handle or not.


            At first I thought it was a problem with my wireless keyboard but it does the same with a USB one, but cannot get it to work incorrectly when using Shift hotkey on the Wacom tablet with either the pen or my mouse?

            Smart Guides or Snap to Guides do not make a difference being on or off. I have restarted and reset preferences.


            If that is how it is designed to work then it is just odd that using the tablet hotkey makes it act differently.

            Using Windows 7,  InDesign CC 2017.1 ( and Wacom driver 6.3.23-1

            • 3. Re: Shift + resize not constraining proportions whilst using smart guides?
              Michael Witherell Adobe Community Professional

              BTW, in InDesign, you should not have Smart Guides turned on AND Snap to Grid turned on, too. They fight with each other. Can you check to see if that is also going on in your case?

              1 person found this helpful
              • 4. Re: Shift + resize not constraining proportions whilst using smart guides?
                bhousto90 Level 4

                Ok thanks, good to know about the Smart Guides/'Snap to' conflict info.


                I just found the answer to my own problem by disabling 'Sticky keys' in Windows Ease of Access settings.

                (And I guess that setting does not apply to a mapped keystroke for a Wacom Express key, so that is why it worked ok with the tablet?)


                With the 'Sticky keys' setting turned off everything seems to be working correctly now.