1 2 Previous Next 42 Replies Latest reply on Aug 20, 2017 8:40 PM by martyc65902188

    Cant use LR 5.7.1 even I already purchased.

    kim7913 Level 1

      I already have LR 5 CD but I can not use 5.7.1 which require me a serial number but mine doesn't work at all. How come?

        1 2 Previous Next