6 Replies Latest reply on Jul 7, 2006 11:02 AM by HS_QA_-_Farah

    Eclipse + Flex Builder Plugin + RDS

    justincarter
      Hi All,

      I've got a strange problem with Eclipse and the Flex Builder and RDS plugins. I configure the RDS connection in Window->Preferences->RDS Settings however when I Test the connection I keep getting the error message "Unable to contact RDS server 'localhost'". I have the settings configured exactly the same as they are in HomeSite+. HomeSite+ can connect fine, but Eclipse cannot!

      Has anyone come across this issue or knows of a workaround? Do I have to install something in a particular order?

      Thanks for any help.
        • 1. Re: Eclipse + Flex Builder Plugin + RDS
          justincarter Level 1
          Sorry the correct error message is "Unable to contact the RDS server 'localhost'"

          I should also clarify that I get the same result in both Eclipse using the Flex Builder plugin and in the standalone Flex Builder application.

          The exact settings I am using are 127.0.0.1 on port 80 and have even resorted to using no password and still not having any luck.
          • 2. Re: Eclipse + Flex Builder Plugin + RDS
            HS_QA_-_Farah
            Could you please let me know the CF version, install configuration and OS? CF versions 6.1 and prior are not supported by the RDS plugin.

            We had a similar issue in beta 1 that got fixed and it was related to the password. If the CF version is not the problem, please email me your RDS password directly at fgron@adobe.com. I know you tried using no password - did you mean the server admin password or the RDS password (you cannot have a blank RDS password)?

            The order of installing plugins doesn't make a difference.

            Thanks,
            Farah

            • 3. Re: Eclipse + Flex Builder Plugin + RDS
              davidmedifit Level 1
              I'm wondering if you guys ever came up with a solution to this problem? I uninstalled, and re-installed Flex Builder 2, and I still have the issue. I also tried the "Test connection" button and get told I cannot connect to localhost.

              Any help is appreciated.

              David
              • 4. Re: Eclipse + Flex Builder Plugin + RDS
                HS_QA_-_Farah Level 1
                David,

                I didn't get any further information from Justin and other than you we don't know of any other incidents where localhost won't work. Please email me (fgron@adobe.com) with a time and day that we could set up a Breeze session with you and try to debug it on your machine.

                Thanks,
                Farah

                • 5. Re: Eclipse + Flex Builder Plugin + RDS
                  davidmedifit Level 1
                  Farah,
                  I've had much better success today - I changed the port number on the RDS preferences in FB2 preferences from the default 8500 to 80. I'm not sure if that is the right thing to do, but it has solved my initial problem, and allowed me to select the data sources I set up on my local machine.

                  I'll post back if I run into other issues - thanks for your help so far.

                  David
                  • 6. Re: Eclipse + Flex Builder Plugin + RDS
                    HS_QA_-_Farah Level 1
                    David,

                    The port 8500 is just the default port number and as you figured out, the information in the RDS configuration panel in Preferences has to match your installed web server's port number.

                    Farah