1 Reply Latest reply on Jun 26, 2017 1:15 PM by Daniel Edwards, Apollo

    Very strange shortcut/keyboard problem in PS CC 2017 - Nothing works anymore

    Daniel Edwards, Apollo

      Hello there,

      I usually don't post or ask questions in forums, but this seems to be a rather specific issue. I've seen a lot of posts here and in other forums discussing shortcut issues, but this is something different.

       

      So today my shortcuts, including tools and simple copy paste commands stopped working. I didn't change anything either software or hardware related, I didn't change any settings and I didn't hit buttons I never hit before. Here is what happens:

       

      I first noticed it when I tried switching to the brush tool using B on my keyboard and it didn't do anything. After checking a bunch of shortcuts, I came to the conclusion that out of all keys on my keyboard, only the function keys, holding 'space' toggling the hand tool, holding 'right Alt' for tool function, toggling viewing modes using 'tab' and hitting 'left alt' to access the top menu (File, Edit...) are working. Even simple stuff like Ctrl+C, Ctrl+V and even Ctrl+N aren't working. Nothing happens as if the keys don't even exist. So I opened a text document, all keys work - I tested them in Premiere, there I only tested C and V for cut and move tool and copy paste, but it all works fine. So I started resetting my Photoshop preferences and even did a reinstall, but nothing changed.

       

      Now here is the really strange part and hopefully what might help to solve this:

      When in the move tool, holding and releasing 'Ctrl' makes the 'Auto select' box check and uncheck.

      It seems as if my keyboard is only accessing the tool option menu.. as if it's another window I can't click out of.

      And when inside the text tool all keys seem to work as far as typing goes, but ofc. shortcuts are still broken. (I also can't copy-paste text)

       

      When trying to set new shortcuts in the keyboard shortcuts menu, the only keys I can set are the number keys on the number block. So when editing one of the shortcuts, it highlights (for example) 'B' which is ofc. already set, but it doesn't do anything no matter what key I hit, except for the num lock keys.

       

      What should I do?

       

      Here a list of things about my system and things I already tested:

      I don't think this is hardware related, but the things that could matter are the following:

      - I'm using Windows 10 pro 64bit on a desktop PC with (I'd like to think) decent hardware. (AMD FX-8350, Nvidia geforce gtx 770, 32gigs of RAM, SSDs)

      - I use a Wacom tablet, but I already tried unplugging it and a bunch of other different stuff. (Tablet settings,...)

      - I tried unplugging the keyboard, also tried using a different one - still the same behavior.

       

      Already tested (software):

      - Restarting Photoshop

      - Restarting PC

      - Resetting preferences

      - Trying to set new shortcuts (More about that above ^^^^)

      - Testing shortcuts in other (Adobe) software - Pr, Ae, Dw - all are working fine, also other non-Adobe software, this only happens in Photoshop.

      - I checked for updates, there actually were some bug fixes, but that didn't change anything.

      - Reinstalling Photoshop, keeping the settings. (CC App)

      - Reinstalling Photoshop, deleting all settings. (CC App)

      - Manually deleting Photoshop and then installing it again using the CC app.

      - Hitting every key on my keyboard at least once and throwing it out of the window.

       

      Well, I think I kind of ran out of options now. I could reinstall windows, but I'm really uncertain this would change anything. Like I said, I didn't do anything different and only Photoshop seems to be affected by this. This would be a really really weird windows bug.

       

      I hope someone might have an idea about what's going on here.

      Many thanks in advance

        • 1. Re: Very strange shortcut/keyboard problem in PS CC 2017 - Nothing works anymore
          Daniel Edwards, Apollo Level 1

          I actually fixed it...

           

          After again testing several different keyboards, I came across a keyboard with a different layout.

          Apparently installing a different Windows language pack fixes everything, even using the default pack... It doesn't make a lot of sense to me, but it works for some reason... It would explain it if the normal pack was broken for some reason, but that should've broken other applications as well. It would only explain a messed up keyboard layout, but not one single app not working.

           

          I don't understand it, but who cares - Turns out it really was a Windows bug.