8 Replies Latest reply on Jun 29, 2017 10:53 AM by Lex van Oorspronk

    How to get rid of the grid overlay

    Lex van Oorspronk Level 1

      Sometimes when I do a crop or a lens correction, the grid won't go away after I completed the action. I can sometimes get it away by clicking on a few tools, but other times I have to restart Lightroom to get rid of it. Is there an easy solution for this?

       

      PS: I don't mean the loupe grid option.

        • 1. Re: How to get rid of the grid overlay
          Abambo Level 4

          Do you mean the "cropping grid"?

           

          Push escape to get out of the current active tools.

          • 2. Re: How to get rid of the grid overlay
            Lex van Oorspronk Level 1

            Yes, I think it's the cropping grid. Pressing Escape does not work to get rid of it.

             

            I found that the first time I use vertical adjustment, the grid does not go away. However when I use vertical adjustment for a second or third time, the grid goes away after I complete the action.

             

            I also just discovered that the grid will go away when I hover with my mouse over the histogram That's a good workaround for something I begin to think is a bug.

            • 3. Re: How to get rid of the grid overlay
              Abambo Level 4

               

               

              Escape, Button DONE or Button CLOSE should do the affair.

               

              What about posting the LR and OS version?

              • 4. Re: How to get rid of the grid overlay
                Conrad C Adobe Community Professional & MVP

                The grid overlay behavior for the Crop tool and the Transform panel are independent of each other, so you handle them separately.

                 

                For the Crop tool, whether the overlay displays or not depends on the setting that you see in the Tool Overlay option in the toolbar below the image. If you don't see a toolbar below the image, choose View > Show Toolbar (or press its toggle shortcut, the T key). Tool Overlay can be set to Auto, Always, or Never. Auto means it only shows up while you're dragging the crop rectangle.

                 

                For the Transform panel, the grid overlay is controlled by two things. One is whether you are holding the pointer over any of the Transform sliders. If you are, then the overlay appears. When you move the pointer away, it disappears. When you said "the grid will go away when I hover with my mouse over the histogram…" It's not a workaround, that's the way it's supposed to work. The grid went away because you stopped hovering over any Transform slider, not because you hovered over the histogram specifically.

                 

                The second thing that affects the Transform panel is the Tool Overlay setting (Tools > Tool Overlay submenu). This is one thing that the Crop tool and the Transform panel have in common: If you don't want the grid to appear, choose Tools > Tools Overlay > Never Show (or press its toggle shortcut, the H key).

                 

                What you observed seems to be explainable by how the program normally works and you have control over it; it doesn't look like there's a bug.

                • 5. Re: How to get rid of the grid overlay
                  Abambo Level 4

                  The crop grid stays, depending on your settings, as long as the crop tool is available. Switching to other tools or closing the crop tool should get rid of the grid.

                   

                  For the transform panel, the grid shows when I hover over the transform sliders. I do not know of a possibility to get a persistent grid with the transform tool as described by the OP.

                  • 6. Re: How to get rid of the grid overlay
                    Conrad C Adobe Community Professional & MVP

                    Abambo  wrote

                     

                    The crop grid stays, depending on your settings, as long as the crop tool is available. Switching to other tools or closing the crop tool should get rid of the grid.

                    No, even if the crop tool remains fully active, pressing the H shortcut will hide the grid overlay.

                    • 7. Re: How to get rid of the grid overlay
                      Abambo Level 4

                      That's why "depending" is for! "H" toggles "Always" and "Never"! It's not working by hovering sliders in contrast to the transform-tool-sliders.

                       

                      The OP, however, says that hovering the histogram gets rid of the grid. I cannot reproduce this behavior.

                      • 8. Re: How to get rid of the grid overlay
                        Lex van Oorspronk Level 1

                        After trying some more I now realise that this is a rare finding

                         

                        But I can now reproduce it:

                        1. open a photo in the develop module
                        2. go to Transform, select Vertical (click on the value not the slider) and change it a little using the cursor keys
                        3. carefully move the mouse upwards and to the left and click on the Transform panel before the Vertical slider
                        4. the grid is fixed and won’t go away with escape or clicking on crop

                         

                        I have the grid overlay set to Automatic.

                         

                        I have Lightroom 2015.10.1 running on an iMac with MacOS Sierra 10.12.5