8 Replies Latest reply on Jul 6, 2017 5:17 AM by adityal16589180

    PhoneGap Build Plugins not working

    adityal16589180 Level 1

      For last 3 days I am struggling with PhonegapBuild Plugins

       

      Below are my observations

      1. All Plugins were working 3 days before (On both iOS and Android)
      2. Then I created a new provisioning profile and p12 for including APNS Notifications
      3. Deleted all the old provisioning profiles and p12 (That was a mistake I feel)
      4. After that no plugin is working on both iOS and Android Device
      5. I can see all the plugins successfully loaded on PhoneGap Build Website Plugins Tab and App Building without error.

       

      Devices Used:

      Iphone 6s - iOS v10.3.1

      Samsung - Android 4.1.2

      AppID: 2689758

       

      Here, all the javascript alerts are working from DeviceReady, except when I reach the call to Device plugin or Notification Plugin, nothing happens.

      As the same observations are there on Android device as that of iOS, I hope my provisioning profile and p12 are correct.

       

      Troubleshooting steps tried:

      1. I deleted the app completely and re-uploaded but still not working
      2. I checked that I have included both Cordova.js and phonegap.js at root in index.html without copying the file itself to my root folder

      <script type="text/javascript" src="cordova.js"></script>

      <script type="text/javascript" src="phonegap.js"></script>

      1. config.xml is stored at the root folder

       

      Below are the plugins used

       

      <preference name="android-build-tool" value="gradle" />

        <plugin name="cordova-plugin-calendar" source="npm" />

          <plugin name="cordova-plugin-device" source="npm" />

        <plugin name="cordova-plugin-contacts" source="nom" />

          <plugin name="cordova-plugin-globalization" source="npm" />

          <plugin name="phonegap-plugin-push" spec="1.5" source="npm">

          <param name="SENDER_ID" value=“xxxxxxxxxxxx” />

        </plugin>

       

      Questions:

      1. Is there something that I am missing from setup perspective ?
      2. Is there a chance I am having some syntax problem in code ?

       

      Message was edited by: aditya lele Additional Observation Here: When I hydrate the App I am observing wierd error Message "Whoops, looks like an error occured." failed to copy Cordova.js With 2 buttons Retry and Go Back If I hit Retry then it loads again with same error. I downloaded the .ipa file and unpacked it and found an load_failed.html and load_failed.js files in it. Files stored at below link <script src="https://gist.github.com/anonymous/e41d8beeeb678824bcbca77460b2373e.js"></script>