4 Replies Latest reply on Jul 2, 2017 5:18 AM by alicemarshall

    Can't change fill colour or alter swatches

    alicemarshall

      Hi there,

       

      I recently formatted my computer (Mac) and re-installed my Adobe products. I'm only having issues with InDesign.

       

      I can't seem to change anything within the swatches panel (unless I create a new colour swatch). If I create a new text box and type some text, I can't change the fill or stroke colour of highlighted text. If I highlight the text and create a new colour swatch, I can apply it within that text box. If I create a new text box or go back to the original box, I can no longer apply that new swatch nor others. I can't delete any of the swatches either. The same issue occurs for objects.

       

      I did manage to format my computer and InDesign worked for about a week, until just yesterday I opened a file which I had worked on previously that day, and I yet again could not alter any colours or swatches, so the problem has re-appeared again.

       

      I have trashed my InDesign preferences, I have worked on old files and new files, I have upgraded from Adobe CS6 to CC, and I have deleted all traces of Adobe products and re-installed and the issue still remains.

       

      The only thing I can do is work on my Windows desktop computer (either Adobe CS6 or CC), where everything works fine, thankfully, however I use InDesign on my MacBook Pro every day for both university and work, thus it is incredibly important the program works!!!!

       

      I am incredibly frustrated by this issue as I have now spent hours on it, including multiple installs and formatting my computer. I have no idea what to do. I can't find anyone else with the same issue.

       

      I'm using Mac OS Sierra.

       

      Can anyone help me?!??

        • 1. Re: Can't change fill colour or alter swatches
          Zaid Al Hilali Adobe Community Professional

          There are known compatibility issues with Mac OS Sierra, but not sure if yours is related. Any way make sure to update your OS to 10.12.5

          1 person found this helpful
          • 2. Re: Can't change fill colour or alter swatches
            alicemarshall Level 1

            Hmm, okay. I wonder if Sierra has something to do with it. I have already updated to OS 10.12.5. Thanks for your reply!

            • 3. Re: Can't change fill colour or alter swatches
              Bill Silbert Adobe Community Professional

              For problems within the Swatch Panel I've found that deleting InDesign's Caches may be helpful.

              To do so:

              With InDesign closed launch a Finder Window in column view and click on your home folder. With the Option Key pressed choose Library from the Finder Go Menu. Within the Library folder find the “Caches” folder. Within the Caches folder find and delete the entire file “Adobe InDesign”. I find that deleting the cache file completely leads to a lasting change.

              Hopefully this will restore full use of your Swatch Panel.

              If that doesn't work you might try deleting your Indesign Preferences. To do so go back to the Libary folder and within the Library folder find the following two files and delete them: “Adobe InDesign” and “com.adobe.InDesign.plist”. When InDesign is next launched it will create new preference files and the program will be restored to its defaults.

              After you’ve reset up the program (make sure that no document window is open) to your liking, it is a really good idea to create copies of your personalized “mint” preference files (make sure that you quit the program before copying them—that finalizes your customization) and use them in the future to replace any corrupt versions you may need to delete.

              1 person found this helpful
              • 4. Re: Can't change fill colour or alter swatches
                alicemarshall Level 1

                Thanks for your offer Bill but unfortunately deleting the cache files did not help.

                 

                As I mentioned in my first post, I have already deleted the InDesign Preferences to no avail.

                 

                I actually just formatted my computer for the 3rd or so time as it was the only way to fix the issue previously, however the issue is now still present and removing the cache files and preferences again also did nothing to fix the issue.