2 Replies Latest reply on Oct 24, 2008 10:31 AM by Sivajee1

    Flex Wrapper DetectFlashVer Not working for 10.0.12.36

    Sivajee1
      Hello,

      I developed a flex application, and till now most of the users has 9.0.x version of flash player installed on their machine and everything was running fine.
      Few days back one of the user has got the latest FlashPlayer i.e., 10.0.12.36.
      On his machine the application is behaving erroneously. For the first time the app is getting launched properly. Once he closes the app and tried to relaunch, strangely the DetectFlashVer() method in the wrapper is returning false and is saying that flash player is old or could not detect the plugin and user is getting a message "Alternate HTML content should be placed here. This content requires the Adobe Flash Player".

      Attached is the code extract from AC_OETags.js file: I am passing following Flash version values from my wrapper JSP:
      // Major version of Flash required
      var requiredMajorVersion = 9;
      // Minor version of Flash required
      var requiredMinorVersion = 0;
      // Minor version of Flash required
      var requiredRevision = 28;


      Please help me in resolving this issue.

      Rgds
      Sivajee.