2 Replies Latest reply on Aug 20, 2017 10:21 PM by tjuphotogirl64

    Lightroom 5.7 download

    stephanies64937460 Level 1

      I had to revert back to my Lightroom 5 but the latest version I have is 5.2.  I need 5.7 for it to be compatible with my D810.  Can someone help me?