14 Replies Latest reply on Aug 8, 2017 5:22 AM by Roy Marshall

    Can't move objects InDesign Mac on Sierra

    Maurizio Bellissiomo

      I have scoured the forum for this issue and apparently a lot of people have the same problem.

      There are NO working solutions.

      I have only experienced it after upgrading to Sierra.

      I have tried deleting all the preferences.

      I have tried reinstalled InDesign.

      I have tried clean installing Sierra.

      Same thing happens every time: InDesign works fine for a while, then at some arbitrary time during the day I can no longer move objects.

      Objects are selectable, can be moved with the arrow keys, but click and drag with a cursor does not work.

      I also noticed I can not move my dock icons in the macOS desktop when I have this issue with InDesign.

      Restarting InDesign does not help.

      I simply have to log out -OR- restart and then InDesign works fine and dock icons are movable again.

      This is not an acceptable solution for me, nor for anyone else.

      Can Adobe and Apple get together to solve this?