5 Replies Latest reply on Jul 15, 2017 4:25 AM by cribble

    Fractal Noise bug

    cribble

      I have been running into a weird bug with the Fractal Noise effect, where it loses its settings and even renders out with these bugs in both render queue and Media Encoder. The TL;DR: Stacking 2+ Fractal Noise effects on a layer causes it to lose its settings randomly. It's a little hard to reproduce.

       

      Say I have a shape layer the size of the comp with a background fill. I plonk two fractal noises on top: One will be used as grain, so I scale it down to 6, change blend to overlay and knock down the opacity. The next FN will be a wash, so I scale that big (say, 160), set to overlay and fiddle with the opacity to suit again. I then script random(4000) onto evolution so they're constantly changing. In previous versions and projects, this has worked as it should, but in this latest version of AE it'll lose its settings for the FN and I end up with a few frames of how it should look, and a few frames of either/or FN being full opacity, or scale is different.

       

      Just to make sure I wasn't going mad, I also moved the effects to a solid layer, and set the opacity and blend mode to suit. Still got the same issue. Even started fresh re-adding the FN effect again and resetting them up just to check, both normal and continuously rasterized.

       

      So here's on frame 1

      AE_Before.PNG

      Apart from random(4000) doing its thing, I haven't touched anything. I move a frame forward and BAM!

      AE_After.PNG

       

      Really am at a loss for this. For a previous project, this effect worked fine two stacked on a shape layer (which was vital for changing background colours smoothly). Nor is it working on a solid layer (which is not ideal for changing colours much like shape layers).

       

      This wasn't present in version 13.7.1 where this worked fine. I noticed this happening in v14.2 and latest, June update version of After Effects.

       

      Running Windows 10 (latest version, all latest updates)

      i7-4790S / Palit GTX1060 6GB (also latest drivers) / 32GB RAM

       

      Thanks