1 Reply Latest reply on May 23, 2006 11:21 AM by bnailWedge

    Passing variables to Flash,...using new method

    bnailWedge
      This was the method I was using (note the "?pageLoad=$pageLoad"):

      <object classid='clsid:D27CDB6E-AE6D-11cf-96B8-444553540000' codebase=' http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,19,0' width='150' height='710'>
      <param name='movie' value='images/menuSys.swf ?pageLoad=$pageLoad' />
      <param name='quality' value='high' />
      <embed src='images/menuSys.swf ?pageLoad=$pageLoad' quality='high' pluginspage=' http://www.macromedia.com/go/getflashplayer' type='application/x-shockwave-flash' width='150' height='710'></embed>
      </object>

      -----------------------

      After the new method that corrects the ActiveX thing in IE, I am now using this method:

      // embed the flash movie
      AC_FL_RunContent(
      'codebase', ' http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8,0,0,0',
      'width', '150',
      'height', '710',
      'src', 'images/menuSys ?pageLoad=$pageLoad',
      'quality', 'high',
      'pluginspage', ' http://www.macromedia.com/go/getflashplayer',
      'align', 'middle',
      'play', 'true',
      'loop', 'true',
      'scale', 'showall',
      'wmode', 'window',
      'devicefont', 'false',
      'id', 'homepage',
      'bgcolor', '#ececec',
      'name', 'images/menuSys ?pageLoad=$pageLoad',
      'menu', 'true',
      'allowScriptAccess','sameDomain',
      'movie', 'images/menuSys ?pageLoad=$pageLoad',
      'salign', ''
      ); //end AC code

      -----------------------

      The problem I am having is that the $pageLoad variable is no longer passed. I am using PHP to have a variable passed into the src string. Anyone have any ideas? I am guessing that the PHP doesn't like to pass anything to this embed method because it resides in a commented area <!-- -->...but I am not certain. I have even tried to use this method of, 'images/menuSys ?pageLoad=<? $pageLoad ?>'. That doesn't work either. How do we get dynamic variables passed through the embed tags now?