0 Replies Latest reply on Jul 23, 2017 2:02 AM by AmerKapetanovic

    (SOLVED) CC App can't update Lightroom from 215.10 to 2105.12 (manual install does not work either)

    AmerKapetanovic Level 1

      UPDATE:

      Solved by closing Lightroom, deleting the following file:

       

      <Startup Disk>/Library/Application Support/Adobe/AAMUpdaterInventory/1.0/AdobeUpdaterAdminPrefs.dat

       

      My problem was that when I clicked Library from the Finder/Go menu, it took me to <Startup Disk>/<myusername>/Library and there I could find only Application Support/Adobe/AAMUpdater/1.0 which was the wrong one. Deleting the correct file did it for me.

      I will not delete this thread, hoping it can help someone.

      So, for three days I was blind to see that it wasn't the correct Library folder

       

      Original post here:

       

      Hey guys,

       

      I've been pulling my hair for last three days not being able to update Lightroom to the latest version. It all started when I read that version 2015.12 is out and my Creative Cloud App wasn't showing any updates (as it did before). Some people wrote that it helps if I uninstall Lightroom through CC app and it will reinstall the latest version.

       

      The trouble begun there - it installed the base version - 2015.10 with old splash screen Screen Shot 2017-07-21 at 19.47.31.png

       

      When I select the "Check for updates" option within CC App it briefly shows "Up to date" next to Lightroom and it then turns it into "Open" button:

       

      Screen Shot 2017-07-21 at 20.26.34.png

       

      I downloaded the patch installer to 2015.12 but the installation can not start. It appears that it looks for administrative privileges but I run it as administrator. I tried creating another administrator-power account but same happens.

       

      Here is current system info taken from Lightroom (excerpt):

       

      Lightroom version:  CC 2015 [1014445]

      License: Creative Cloud

      Operating system: Mac OS 10

      Version: 10.12 [5]

      Application architecture: x64

      Logical processor count: 8

      Processor speed: 2,5 GHz

      Built-in memory: 16.384,0 MB

      Real memory available to Lightroom: 16.384,0 MB

       

      I searched for solutions at Adobe pages but nothing worked (deleting AdobeUpdaterPrefs.dat, opm.db, etc.)

       

      Then I uninstalled everything using Creative Cloud Cleaner Tool and followed instructions (including restart, etc.), did new installation of CC App and it again downloaded Lightroom CC 2015.10 without option to update.

       

      I tried manual update from the Patch Installer that I downloaded but got this message:

       

      Screen Shot 2017-07-23 at 10.24.54.png

      Again, all is done with administrator account.

      I tried to repair permissions on my drive, there was nothing wrong with it.

       

      I uninstalled everything again through CC Cleaner Tool, restarted and then downloaded core install manually (727 Mb), installed it, signed in and it was core 2105.10 version. When I tried to update manually using Patch Installer it gave me the same error message like above.

       

      To make matters more strange, my Lightroom was updated to the latest version before the newest one and I could have worked on my Fuji X-T2 files. Now I can't import, nor I can work on those that are already in the library.

       

      So frustrating!

       

      I chatted with Support (1st tier) to try to solve it but, to say this nicely, his ignorance was insulting. He even insisted that 2015.10 was the latest version:

       

      (chat excerpt)

      Amer Kapetanovic: ok, can you please check the build number of the latest version of Lightroom?

      Kanishk: The latest version for lightroom is 2015.10

      Kanishk: Are you there?

      Amer Kapetanovic: yes, I am, and trying to understand what you're saying

      Amer Kapetanovic: would you please check out the splash screen I attached?

      Amer Kapetanovic: it says 2007-2015 Adobe Systems Incorporated...

      Amer Kapetanovic: and here is what it should look like at the latest version:

      Amer Kapetanovic: Your file was successfully uploaded: Screen Shot 2017-07-21 at 19.52.17.png.

      Amer Kapetanovic: and please check this link:

      Amer Kapetanovic: https://blogs.adobe.com/lightroomjournal/2017/07/lightroom-cc-2015-12-now-available.html

      Kanishk: Amer the latest version of lightroom is 2015.10, the screen shot which you attached it says 2015.12 release not released.

      Kanishk: As soon as there will any update for your application it will reflect on your adobe desktop application and you can directly do it from your end.

      Kanishk: The 2015.12 version is not released yet

      Amer Kapetanovic: but please look at the link I just copied, are we in some parallel worlds or something?

      Amer Kapetanovic: Can you please escalate my case to higher instance?

      Amer Kapetanovic: useful link: https://helpx.adobe.com/lightroom/kb/keeping-lightroom-up-to-date.html

      Kanishk: My higher instance will also tell you the same information as I am

      Amer Kapetanovic: the latest link says (among rest): The latest/most current version of Lightroom CC is 2015.12

      Kanishk: Let me cross check this information

      Amer Kapetanovic: Ok, fine, please escalate it so I could get the information.

      Kanishk: Right, the latest version is available now 2015.12

       

      So I tried everything I could and got nowhere.

       

      Did anyone had this problem?
      Is there anything I can do?

       

       

      Thanks!