3 Replies Latest reply on Aug 1, 2017 7:53 AM by andya43855007

    Cryptic error - Your ios platform does not have Api.js

    andya43855007

      I am trying to build an app and I am getting this error message.

       

      I am not seeing what is possibly happening - I have an old version that I'm using (I'll upgrade eventually), but as far as I can tell it'll still work:

       

      <?xml version="1.0" encoding="UTF-8" ?>

      <widget xmlns   = "http://www.w3.org/ns/widgets"

      <INFO GOES HERE>

          <access uri="*" subdomains="true" />

         

         

       

       

          <!-- versionCode is optional and Android only -->

       

       

          <name>NAME</name>

         

          <preference name="phonegap-version" value="cli-5.2.0" />

         

          <preference name="orientation" value="portrait" />

       

       

          <description>

      description

          </description>

       

       

          <author href="http://company.io" email="contact@company.io">

              Company, LLC

          </author>

         

          <access origin="http://domain.com" subdomains="true" />

         

          <feature name="Camera">

              <param name="ios-package" value="CDVCamera" />

          </feature>

         

          <plugin name="cordova-plugin-geolocation" spec="https://github.com/apache/cordova-plugin-geolocation.git" source="git" />

          <feature name="Geolocation">

              <param name="ios-package" value="CDVLocation" />

          </feature>

          <feature name="Geolocation">

              <param name="android-package" value="org.apache.cordova.geolocation.GeoBroker" />

          </feature>

       

       

          <plugin name="cordova-plugin-camera" spec="1.2.0" source="npm" />

          <!--<plugin name="phonegap-plugin-push" spec="1.5.0" source="pgb" />-->

          <plugin name="phonegap-plugin-push" spec="https://github.com/phonegap/phonegap-plugin-push.git#1.5.0">

              <param name="SENDER_ID" value="chat-app-143622" />

              <param name="GOOGLE_APP_ID" value="1:763640140170:ios:2c80165fdf57078b"/>

          </plugin>

       

       

          <preference name="android-build-tool" value="gradle" />

       

          <feature name="http://api.phonegap.com/1.0/camera"/>

       

       

          <plugin name="https://github.com/Wizcorp/phonegap-facebook-plugin" source="git" version="0.9.0">

              <param name="APP_ID" value="933416606757546" />

              <param name="APP_NAME" value="NAME" />

          </plugin>

       

       

      </widget>

       

       

      What would possibly be causing this? I'm not understanding the problem.