1 Reply Latest reply on Aug 1, 2017 11:16 AM by 99jon

    If I were to upgrade to a current OS 10.13, would my Lightroom 4 e still compatible?

    brian heckl

      I  have Lightroom 4.4.1 running on 2009 MacBook Pro with OS 10.7.5. Every thing works great for my business but my Safari is getting incompatible with certain sites. If I were to upgrade to a current OS 10.13, would my Lightroom 4 e still compatible?