4 Replies Latest reply on Aug 8, 2017 1:24 PM by kerrishotts

    Help with Error During Build

    Chris Stead Level 1

      Hi Guys,


      Experimenting with PhoneGap for the first time, and have an error when building I don't know where to start on. Any ideas. At the end of the long Log File it says:


      ** ARCHIVE FAILED **



      The following build commands failed:

      CompileAssetCatalog /Users/phonegap/Library/Developer/Xcode/DerivedData/The_Little_Green_Boat-geeewvhgufdwyhh bymzufjxsmyna/Build/Intermediates/ArchiveIntermediates/The\ Little\ Green\ Boat/InstallationBuildProductsLocation/Applications/The\ Little\ Green\ Boat.app The\ Little\ Green\ Boat/Images.xcassets

      (1 failure)

      Error code 65 for command: xcodebuild with args: -xcconfig,/private/tmp/gimlet/2738908/project/cordova/build-release.xcconfig,-workspace,T he Little Green Boat.xcworkspace,-scheme,The Little Green Boat,-configuration,Release,-destination,generic/platform=iOS,-archivePath,The Little Green Boat.xcarchive,archive,CONFIGURATION_BUILD_DIR=/private/tmp/gimlet/2738908/project/build/ device,SHARED_PRECOMPS_DIR=/private/tmp/gimlet/2738908/project/build/sharedpch

      /Users/phonegap/gimlet/bin/system_ruby: line 22: shell_session_update: command not found


      Thanks in advance


      [Moved from the Lounge (which is where you can "connect with your peers" from across all of Adobe's products for conversations that don't directly relate to help and support) to a product-specific support forum by a moderator.]

        • 1. Re: Help with Error During Build
          kerrishotts Adobe Employee

          What's your environment like (OS version, Xcode version, etc.)?

          • 2. Re: Help with Error During Build
            Chris Stead Level 1

            Just uploading it through Windows 10. The package is HTML 5 (exporting from indesign using the In5 plugin), and using Configap to generate the config.xml


            I've previously done it to test without a problem, but now it is generating this error which makes no sense to me.

            • 3. Re: Help with Error During Build
              Chris Stead Level 1

              Interesting update - if I set the config file to point to Phonegap 6.5.0, it compiles just fine and this error does not show. So it would appear to be something that the new Phonegap 7.0.1 is trying to compile, that Configap doesn't attribute in the config.xml. At least, that is my rookie estimate of the problem.


              But how to solve? Here is my current config file if that helps. Thanks for your help Kerrishotts


              <widget xmlns = "http://www.w3.org/ns/widgets"

              xmlns:gap = "http://phonegap.com/ns/1.0"

              xmlns:android = "http://schemas.android.com/apk/res/android"

              id        = "com.oldmatemedia.willy1"


              version   = "">

              <name>The Little Green Boat </name>

              <description>This is the app version of The Little Green Boat children's picture book. </description>

              <author href="http://www.oldmatemedia.com" email="chris@oldmatemedia.com">Chris Stead </author>

              <feature name="http://api.phonegap.com/1.0/battery" />

              <feature name="http://api.phonegap.com/1.0/camera" />

              <feature name="http://api.phonegap.com/1.0/contacts" />

              <feature name="http://api.phonegap.com/1.0/file" />

              <feature name="http://api.phonegap.com/1.0/geolocation" />

              <feature name="http://api.phonegap.com/1.0/media" />

              <feature name="http://api.phonegap.com/1.0/network" />

              <feature name="http://api.phonegap.com/1.0/notification" />

              <preference name="phonegap-version" value="cli-6.5.0" />

              <preference name="android-build-tool" value="gradle" />

              <preference name="orientation" value="default" />

              <preference name="fullscreen" value="true" />

              <preference name="target-device" value="universal" />

              <preference name="webviewbounce" value="true" />

              <preference name="prerendered-icon" value="false" />

              <preference name="stay-in-webview" value="true" />

              <preference name="ios-statusbarstyle" value="default" />

              <preference name="detect-data-types" value="true" />

              <preference name="exit-on-suspend" value="true" />

              <preference name="show-splash-screen-spinner" value="true" />

              <preference name="auto-hide-splash-screen" value="true" />

              <preference name="FadeSplashScreen " value="true" />

              <preference name="EnableViewportScale" value="false" />

              <preference name="MediaPlaybackRequiresUserAction" value="false" />

              <preference name="AllowInlineMediaPlayback" value="true" />

              <preference name="BackupWebStorage" value="none" />

              <preference name="TopActivityIndicator" value="white" />

              <preference name="KeyboardDisplayRequiresUserAction" value="true" />

              <preference name="KeyboardShrinksView " value="true" />

              <preference name="HideKeyboardFormAccessoryBar" value="true" />

              <preference name="SuppressesIncrementalRendering" value="false" />

              <preference name="windows-identity-name" value="" />

              <preference name="android-installLocation" value="auto" />

              <preference name="SplashScreenDelay" value="2000" />

              <preference name="ErrorUrl" value="null" />

              <preference name="BackgroundColor" value="0x000000" />

              <preference name="DisallowOverscroll" value="true" />

              <preference name="LoadingDialog" value="," />

              <preference name="LoadUrlTimeoutValue" value="null" />

              <platform name="ios">


              <platform name="android">


              <platform name="winphone">


              <icon src="icon.png" />


              • 4. Re: Help with Error During Build
                kerrishotts Adobe Employee

                Those <feature> tags should not be there. You'd normally be using a plugin tag to source a plugin.


                Version is blank -- you need to fill that in.


                versionCode isn't a valid attribute.


                You're also missing a lot of icons that iOS will require (and also launch images), but that wouldn't cause that particular error (I don't think).