1 Reply Latest reply on Aug 20, 2017 11:37 AM by dews

    APP Hangs: does not have sandbox access for frZQaeyWLUvLjeuEK43hmg

    dews Level 1

      Air 26/Feathers 3.3.0 - iOS 10.3.3 - MAC (10.12.6)

       

      In development - the following shows up in the system console when the APP starts and the APP then continues to run without issue:

       

      1) libMobileGestalt MobileGestaltSupport.m:153: pid 1509 (APP) does not have sandbox access for frZQaeyWLUvLjeuEK43hmg and IS NOT appropriately entitled

       

      2) libMobileGestalt MobileGestalt.c:550: no access to InverseDeviceID (see <rdar://problem/11744455>)

       

      However, an Ad Hoc build - the APP hangs and does not load anything other than the two lines above:

       

      When searching for rdar://problem/11744455 - it appears this could be to do with the use of:

       

      1) location services

       

      I have an appropriate InfoAdditions key/value:

       

        <key>NSLocationWhenInUseUsageDescription</key>

        <string>This allows you to choose your location when searching</string>

       

      I also check for permissions and prompt the user appropriately with myGeoInstance.requestPermission()

       

      I also do the same for CameraRoll and FileReference (though permissionStatus is always = PermissionStatus.GRANTED for FileReference)

       

      2) Use of StageWebView - I'm allowing a login with FaceBook:

       

      I followed  the instruction here: Getting Started - iOS SDK - Documentation - Facebook for Developers

       

       

      I'm not sure if this helps shed any light - If I run a development build but close the debugging session - so when the APP starts I see the "Adobe AIR: Waiting for Connection" dialogue box - I see the two lines mentioned above (and nothing else) - just like an Ad Hoc build..  When I close the dialogue box, of course the APP runs as expected and the rest of the noise about the APP appears in the console window.

       

      I found a post that describes exactly the same error on 08/02/17 and it was resolved a few days ago on 08/08/17: [QTBUG-57205] QtGraphicalEffects does not include qml files in static builds - Qt Bug Tracker - hopefully this helps @Adobe to troubleshoot or offer a workaround.

       

      I found another post on: Google Groups and the fix was rolled into 08/01/17 Firebase 4.03 Firebase and I believe it was described as:

      (iOS) Fixed a bug which caused method implementation look ups to fail when other iOS SDKs rename the selectors of swizzled methods. This could result in a hang on startup when using some iOS SDKs.

       

      As always, ty in advance for your help.

        • 1. Re: APP Hangs: does not have sandbox access for frZQaeyWLUvLjeuEK43hmg
          dews Level 1

          I built a sample project - Feathers 3.3.0 - with just a simple button.  I get the same two lines described but it doesn't prevent an Ad Hoc or Production build, so something else is going on.  Hopefully those two lines don't cause a rejection from the APP Stores and we can just ignore them.

           

          As it turns out, the reason was to do with Assets not being loaded.  Issue for us was two fold, hopefully this will help someone and encourage some better documentation to highlight this.  The most frustrating fact in this is that everything worked in a Fast and Standard build.

           

          • Asset paths were not being honored.  Even though the assets were in the "bin-release-temp" directory and using the Starling Asset Manager to load them, so we never even considered that perhaps they weren't being included in the final .ipa
          • An event notifying our framework to proceed was occurring before the framework was actually ready because there was no delay in loading assets
            (Granted this should not have been the only place for a "ready" event regardless)

           

          In hindsight, simple problems are always the most painful.