1 Reply Latest reply on Aug 31, 2017 11:35 PM by c.pfaffenbichler

    Photoshop 2017 isn't working

    PurpleNightOwl

      I know the title to my problem sounds vague, but it's hard to put into a few words. Photoshop has been working flawlessly since I got it a few years ago, until now. I'm really panicking here because I use Photoshop a lot. Anyway, the problem is, I wanted to create my own crosshair image for a Unity project I'm making, so I went into Photoshop as usual and make a 1024x1024 pixel file. The first thing I notice is that the background is black instead of the default white colour, and I checked the background colour and it was supposed to be white. I try correcting this by using the Fill tool to make it white but I get an error: Could not use the Fill tool because of a program error. I tried the Brush tool, same thing. I'm really baffled. I can't add any new layers either, I can't delete the default background or even unlock it. There's something seriously wrong with my program at the moment.

      I tried checking if Photoshop was the most recent version and checked for updates, and it was up to date. My anti-virus security program is in the green (I have Norton 360). I tried opening an old Photoshop file and it was working absolutely fine. The hard drive that Photoshop uses the scratch disks for is fine. I just can't make any new files. I'm really worried that it's somehow got corrupted. I did notice that when I went to log in the Adobe CC panel where I can update my applications, it initially said there was an issue with my firewall or something, but I clicked Retry and I just logged in and it seemed fine. I haven't had any updates on my PC recently. I think I moved a few files around on my hard drive (not my C: hard drive but my other one I use) to make it more organised, but I wouldn't have thought that would affect anything.

      I'm a bit frazzled. Has anyone got any suggestions or experienced this before? I'm worried I might have to reinstall Photoshop (I really hope I don't have to). Everything else is running fine on my PC. There's no obvious viruses or anything. Norton isn't picking anything up. The last time I used Photoshop was when I was editing some UV maps exported from 3DS Max, and it was fine then.

       

      UPDATE: Typical. I get all worried and put a frantic long-winded post up, and the stupid thing seems to have fixed itself. Never mind, sorry.