2 Replies Latest reply on Mar 15, 2018 7:14 AM by susana88615587

    “Cannot extract the embedded font...”  grrr...

    Taliesin64 Level 1

      I was trying to export a PDF of an InDesign file today when I got this error message:

       

      Cannot extract the embedded font 'XVESDR+FontName'. Some characters may not display or print correctly.

       

      The resulting PDF does not display the correct font, and seems to make a substitution. The type is legible — but in the substituted font. I tired to open the file in Preview on my Mac and it displays the font, but the characters are all garbled — so it's illegible.

       

      Now, here's the crazy thing about this:

       

      The file, let's call it "Test 2", started as a copy of a file, let's call it “Test 1." I'd been exporting Test 1 for a couple of weeks with no errors. In fact, I've never encountered this error before in twenty-plus years of using Acrobat.

       

      I just made a copy of Test 1 and flowed in all new text from a PDF source file to make Test 2. It has all the same styles, etc, as Test 1.

       

      So I poked around on these forums and someone suggested the font was corrupt — except I went back and opened Test 1 in InDesign and re-exported to PDF and I did NOT get the error, and the PDF was made just fine. So it's NOT the font, as Test 1 still makes a PDF, no problem, and the font displays correctly and everything.

       

      Several forum posts suggested a patch, but I'm running the most up-to-date version of Acrobat Pro DC. There is no patch, that I can find.

       

      So now I'm stuck, with a deadline looming (of course). I have no idea how to troubleshoot this now.

       

      Any ideas on how to ameliorate this issue once and for all?

       

      Thanks,

       

      M.

        • 1. Re: “Cannot extract the embedded font...”  grrr...
          Taliesin64 Level 1

          Nothing? I've waited patiently for ten days here and have tried every workaroud/troubleshooting experiment I can think of and I still have not found a solution to this problem. None of the other forum posts have a solution, that I can find. It's a BIG problem!

           

          I tried saving the file as an IDML and starting over. Still had the font problem. I tried starting a brand new document and imported all my styles from the doc that does export just fine with this font — still had the font problem. I tried reexporting to PDF from my original "good" document again to make sure — and the font issue does NOT appear. Don't know what's different about this doc than all the other tests I've tried.

           

          So I tried importing all of my text from Word, thinking it may have something to do with cutting and pasting — sometimes had the font problems and sometimes not, in the same document.

           

          So then I tried saving my Word doc as plan text, cutting and pasting into a new document and just changes a few lines to my font — had the font problem.

           

          But I can still go back to my original document and it export just fine. Aaargh. Is it somehow possible that the font has been corrupted (a suggestion I saw when Googling this problem) but somehow it's NOT corrupted in the one doc that's performing as expected? Do the fonts get embedded somehow so that it's not spoiled in one doc, but spoiled everywhere else? And how to explain that it will sometimes screw up and sometimes not — from page to page in the same doc?

           

          I am now in something very close to a panic. Can someone at ADOBE help me?

           

          Thanks,

           

           

          M.

          • 2. Re: “Cannot extract the embedded font...”  grrr...
            susana88615587 Level 1

            Go to your Indesign file. Using the selection tool (V) select the block of text that is not embedding properly. Go to the Type, drop down to Create Outlines. This will convert the text to outlines. Export the PDF.

             

            This will make the Indesign text NOT able to be edited as its now a shape. So, either save as a different file name. Or, undo the last step.

             

            S.

            1 person found this helpful