4 Replies Latest reply on Sep 5, 2017 9:10 AM by rombanks

    Saving FM15 as MIF 6.0 - Impossible?

    rombanks Level 1

      Hello fellows,

       

      I am trying to save an FM15 file as MIF6.0 using a script but the output MIF file contains some gibberish.

       

      It seems that in FrameScript, the following doesn't work:

      Save Document DocObject(myDocVar) File(myOutFileName) FileType(SaveFmtInterchange60);

       

      Please, advise!

       

      Thanks,

      Roman

        • 1. Re: Saving FM15 as MIF 6.0 - Impossible?
          frameexpert Level 4

          Hi Roman,

           

          There is no such parameter as SaveFmtInterchange60. Use SaveFmtInterchange70 instead and your MIF file will be compatible with FrameMaker 6.

           

          Rick

          • 2. Re: Saving FM15 as MIF 6.0 - Impossible?
            rombanks Level 1

            Hi Rick,

             

            Thank you for your response!

            SaveFmtInterchange70 creates MIF 7.0. Are there any differences between MIF6.0 and MIF 7.0?

             

            I guess Framemaker 6 was only able to create MIF6.0, right?

             

            Thanks,

            Roman

            • 3. Re: Saving FM15 as MIF 6.0 - Impossible?
              frameexpert Level 4

              Yes, each FrameMaker version creates its own "version" of MIF. The only reason that there is still a MIF 7.0 option is that FrameMaker 7 is the last version before FrameMaker went to a Unicode character set instead of FrameRoman. So any version below 8 will handle MIF 7.0 correctly.

              • 4. Re: Saving FM15 as MIF 6.0 - Impossible?
                rombanks Level 1

                Hi Rick,

                 

                Thank you for your response!

                 

                I need to replace a legacy MIF file created with FM 6.0 with a new one. The legacy MIF file served as a template for MIF files generated out of XML files. The only problem is that if I save the new template file as MIF 7.0 or later, the file generated from XML contains an extra blank page at the beginning of the file. With the old template, it worked fine and didn't add any blank pages. I checked the pagination and master page usage settings and they are identical in both the old and the new templates. So I hoped that saving the new template as MIF 6.0 would somehow resolve the issue. But it appears that I can't save as MIF 6.0. Saving as MIF7.0 doesn't help, so saving as MIF6.0 wouldn't have helped either, I guess...

                 

                Best Regards,

                Roman