0 Replies Latest reply on Sep 14, 2017 9:55 AM by jbrock777

    CF10 cfindex NoSuchMethodError - resolution

    jbrock777 Level 1

         Solved a problem today that I doubt Adobe will patch in cf10, so here you go.

       

      System Specs :

      Windows Server 2008 R2

      Coldfusion 10 10,0,23,302580

      Java 1.8.0_74

       

       

      Symptom (from the exception.log):

       

      java.lang.NoSuchMethodError: org.openxmlformats.schemas.wordprocessingml.x2006.main.CTFFData.getCheckBoxList()Ljava/ut il/List;

      at org.apache.poi.xwpf.usermodel.XWPFRun.text(XWPFRun.java:1001)

      at org.apache.poi.xwpf.usermodel.XWPFRun.toString(XWPFRun.java:971)

      at org.apache.poi.xwpf.usermodel.XWPFParagraph.getText(XWPFParagraph.java:215)

      at org.apache.poi.xwpf.usermodel.XWPFTable.<init>(XWPFTable.java:117)

      at org.apache.poi.xwpf.usermodel.XWPFDocument.onDocumentRead(XWPFDocument.java:152)

      at org.apache.poi.POIXMLDocument.load(POIXMLDocument.java:166)

      at org.apache.poi.xwpf.usermodel.XWPFDocument.<init>(XWPFDocument.java:118)

      at org.apache.poi.xwpf.extractor.XWPFWordExtractor.<init>(XWPFWordExtractor.java:59)

      at coldfusion.tagext.search.MSDocument.readDocx(MSDocument.java:164)

      at coldfusion.tagext.search.SolrUtils.getSolrDocument(SolrUtils.java:734)

      at coldfusion.tagext.search.SolrUtils.addDocument(SolrUtils.java:1349)

      at coldfusion.tagext.search.IndexTag.doUpdate(IndexTag.java:675)

      at coldfusion.tagext.search.IndexTag.doStartTag(IndexTag.java:353)

      at coldfusion.runtime.CfJspPage._emptyTcfTag(CfJspPage.java:2795)

       

       

      Resolution :

       

      Step 1. Download ooxml-schemas-1.1.jar : http://central.maven.org/maven2/org/apache/poi/ooxml-schemas/1.1/ooxml-schemas-1.1.jar

      Step 2. Rename ooxml-schemas-1.1.jar to ooxml-schemas.jar and copy into C:\ColdFusion10\cfusion\lib

      Step 3. Restart Coldfusion instance

      Step 4. Perform a happy dance and run through the hallways rejoicing that the index feature works once more!!!