6 Replies Latest reply on Sep 24, 2017 2:55 AM by Peter Grainge

    Can't install RoboHelp 2017 Update 2

    Tech Comm Tools Adobe Community Professional

      Alas, the error log they mention is not available!

      Anyone else seen/solved this?

      Screenshot 2017-09-18 12.40.26.png

        • 1. Re: Can't install RoboHelp 2017 Update 2
          Peter Grainge Adobe Community Professional

          How did you try to apply the update? If it was via File > Help, try downloading the update first.

           

          Adobe - Support : RoboHelp Support Center : Service Releases

           

          The only time I have seen this message, the log file was available, albeit not much help.

           


          See www.grainge.org for RoboHelp and Authoring information

           

           

          @petergrainge

          • 2. Re: Can't install RoboHelp 2017 Update 2
            doctester

            I'm having the same problem, and Support Chat didn't have a solution. When I checked for updates using Help > Updates, it didn't find any RoboHelp updates. When I manually downloaded it from the Adobe site and tried to install, I got a message similar to the one above, except mine said that the update was not applicable to my installation. I checked the datestamps on the RoboHelp application directory, and there is nothing new enough to indicate that the update did a stealth installation.

             

            The only suggestion I got from the Support Chat was to (oh joy) uninstall RoboHelp entirely and then re-install it. I was hoping someone here would have a solution. BTW, I also posted this on another thread related to one of the problems this update supposedly fixed. Will repost any answer I get here.

            • 3. Re: Can't install RoboHelp 2017 Update 2
              Peter Grainge Adobe Community Professional

              I got the same message as DocTester but that was because I was running a beta version of RoboHelp 2017 on that machine. If it's any help, uninstalling and then installing the released version did fix the issue.

               


              See www.grainge.org for RoboHelp and Authoring information

               

               

              @petergrainge

              • 4. Re: Can't install RoboHelp 2017 Update 2
                doctester Level 1

                Uninstalling and reinstalling the original RoboHelp 2017 distribution *did* allow RoboHelp to discover and install Update 2. However, when you compile RHTML5 help with the updated RoboHelp, you get the following error:

                 

                The variables titleColor, backgroundColor, logo, and fontFamily are not available in the usersettings.js file.

                You must upgrade your responsive HTML5 layout to the latest version to include these variables, so that the layout appears fine in the generated output. Visit http://www.adobe.com/go/learn_rh_upgrade_html5_layout_en page for information about upgrading your layout.

                 

                Unfortunately, I do not have a usersettings.js anywhere in my RoboHelp environment. Any clues as to whether they changed the name of this file or how it could have gone missing?

                • 5. Re: Can't install RoboHelp 2017 Update 2
                  doctester Level 1

                  Hopefully this is the last word on this issue. I think I see where the usersettings.js confusion may have come it. The error message when you compile RHTML5 in the updated RoboHelp 2017 does not specify that the problem is only for people who have upgraded from RoboHelp 2015, but when you click on the link in the error message, the instructions are for RoboHelp 2015 -> to -> RoboHelp 2017 updates. I'm guessing there isn't (and isn't supposed to be) a usersettings.js file in RoboHelp 2017-created layouts.

                   

                  In any case, the Help looks and functions fine, error message or no, and context-sensitive help displays the way it's supposed to (see Context-sensitive topic appearance - Indigo template (RH2017)   ). The only issues -- the need to uninstall and reinstall RoboHelp 2017 and the apparently bogus error message -- can be worked around.

                   

                  Keep us informed if you run into any other surprises.

                  • 6. Re: Can't install RoboHelp 2017 Update 2
                    Peter Grainge Adobe Community Professional

                    I'm guessing that it is more that with the old layout the usersettngs were wrong and then when you updated to the new layout, that corrected things. It's not a file you should have to access.

                     


                    See www.grainge.org for RoboHelp and Authoring information

                     

                     

                    @petergrainge