0 Replies Latest reply on Aug 13, 2008 1:18 PM by babak1

    WebServices and Flex Builder 3.0

    babak1
      Hi

      I am trying to call a web service using Flex builder wizard and MXML and here is my code.

      I can call web service but I am not getting any result back.
      Would appriciate any help.

      P.S I have used import web service to create a classes for following wsdl

      http://weblogic.macromedia.com/mxna/webservices/mxna2.cfc?wsdl

      Thank you.


      <?xml version="1.0" encoding="utf-8"?>
      <mx:Application xmlns:mx=" http://www.adobe.com/2006/mxml" xmlns:srv="com.macromedia.*"
      layout="absolute"
      creationComplete="wsBlogAggr.getMostPopularPosts_send()">
      <srv:Mxna2Service id="wsBlogAggr">
      <srv:getMostPopularPosts_request_var>
      <srv:GetMostPopularPosts_request daysBack="30" limit="30"/>
      </srv:getMostPopularPosts_request_var>
      </srv:Mxna2Service>
      <mx:Panel x="10" y="10" width="475" height="400" layout="absolute"
      title="Most Popular Posts">

      <mx:ComboBox x="30" y="25" id="cbxNumPosts" change="wsBlogAggr.getMostPopularPosts_send()">
      <mx:Object label="Top 5" data="5" />
      <mx:Object label="Top 10" data="10" />
      <mx:Object label="Top 15" data="15" />
      </mx:ComboBox>

      <mx:DataGrid x="30" y="75" id="dgTopPosts" width="400" dataProvider="{wsBlogAggr.getMostPopularPosts_lastResult}">
      <mx:columns>
      <mx:DataGridColumn headerText="Top Posts" dataField="postTitle"/>
      <mx:DataGridColumn headerText="Clicks" dataField="clicks" width="75"/>
      </mx:columns>
      </mx:DataGrid>

      <mx:LinkButton x="30" y="250"
      label="Select an item and click here for full post"/>
      </mx:Panel>

      </mx:Application>