4 Replies Latest reply on Oct 5, 2009 12:58 AM by rechtut

    Font Problem

    Level 7
      Hi All,

      I seem to be having an odd problem with an application I've created using
      Director MX2004...

      I have 2 main fonts in a touch screen application - They are embedded into
      Director (using insert>font etc.).

      The thing is, sometimes when the app runs, the font doesnt seem to work and
      it defaults to the standard Arial font (which is much bigger than the
      embedded one and causes problems!).

      I could understand if it didn't work at all, but it's kind of intermittent -
      So, if its not working, and I quit the app and run again it may be working
      the second time!

      I've never had font problems before, so Im sure im doing everything correct.
      I have about 40 PC's with 3 different apps on - and they ALL semm to be
      having this problem?



      The OS is windows XP - PC's are Dells - no other 'strange' software
      installed - literally the OS and the apps

      The main font is Helvetica LT 47 Light Condenses (TrueType).


      Anyone have any ideas?


      Tim


        • 1. Re: Font Problem
          Level 7
          Sometimes the embedded fonts get corrupted and you need to delete the
          font member, then add it in again, then save and compact, then
          republish. Often that will help.

          If not, since this sounds like a program running in a kiosk that you
          have control over, you can get around the problem by installing the font
          into the actual machines (I am assuming that you can legally do this...
          consult with the docs or manufacturer of the font for legal details).
          Once it is installed, you can use it normally without needing to worry
          about embedded versions.

          BuddyAPI has a method baInstallFont() which will make this process quite
          painless (though manually dragging a font into the fonts folder is sort
          of painless anyway...)
          • 2. Re: Font Problem
            rechtut Level 1

            hi tim

             

            i'd love to know if the suggestion you recieved resolved your problem.

             

            i have an identical situation in a museum instalation where the kiosk is repeated 8 times and all 8 are producing a similiar behavior that you describe.

             

            do you know if the problem you describe was something that just kept getting worse as time went by?

             

            thanks

            mz

            • 3. Re: Font Problem
              Sean_Wilson Adobe Community Professional
              i have an identical situation in a museum instalation where the kiosk is repeated 8 times and all 8 are producing a similiar behavior that you describe.

              If it's a kiosk then why not simply install the font and use this system version, instead of relying on a (flaky) embedded font?

              • 4. Re: Font Problem
                rechtut Level 1

                well, could definitely do that and will do it if no other option is available, but as it stands i have close to a thousand text actors in 2 languages and just the idea of having to do that is a bit daunting.

                 

                and not just that...i really would like to understand what gives with the "flaky" fonts. the whole notion of a deteriorating projector seems unlikely. i have been doing director for a very long time and have never had a similiar problem and it was both a schock and a relief to find that i am not the only one with this wierdness on my hands.