3 Replies Latest reply on Oct 23, 2017 11:33 AM by Peter Grainge

    RoboHelp 2017 Compatibility with Older Versions

    SrikrishnaV-TW

      Hi All,

       

      I have recently joined a company as Technical Writer and I have RoboHelp 2017 installed in my system.

       

      Now, when I open older projects (.xpj file) of User Guides to add new topics that I am working on, I am not sure if everything is getting imported. The reason of this doubt is that when I opened a project for the first time in RH2017, there was a message asking to take a back up of the project as RH2017 will upgrade the project to 2017 version. So, I clicked on Upgrade. Then, there were these messages of things not getting imported and I had to click OK or Cancel. So, I checked the 'Do not show me this message' box and clicked OK.

       

      All projects that I open using .xpj, they do open. Issue is I do not know if something is missed out. And, this concerns me as I have to add new topics to the original version of any User Guide I am working on.

       

      Then, there is style (.css) issue. I don't know if the older style is being applied as they are defined by the company. I cannot use a new style.

       

      Third, I want to know whether the projects done / upgraded by me in RH2017 will be compatible with older RH versions or not.

       

      It would be great help if anyone can assist.

       

      Thanks and regards,

      Krishna

        • 1. Re: RoboHelp 2017 Compatibility with Older Versions
          Peter Grainge Adobe Community Professional (Moderator)

          What you haven't said is whether you have previous experience of RoboHelp. I will assume not so forgive me if anything I say is stuff you know.

           

          Now, when I open older projects (.xpj file) of User Guides to add new topics that I am working on, I am not sure if everything is getting imported. The reason of this doubt is that when I opened a project for the first time in RH2017, there was a message asking to take a back up of the project as RH2017 will upgrade the project to 2017 version. So, I clicked on Upgrade. Then, there were these messages of things not getting imported and I had to click OK or Cancel. So, I checked the 'Do not show me this message' box and clicked OK.

           

          All projects that I open using .xpj, they do open. Issue is I do not know if something is missed out. And, this concerns me as I have to add new topics to the original version of any User Guide I am working on.

           

          The reason you are advised to take a backup is mostly so that you have a clean copy if the upgrade goes wrong. I always recommend creating the backup as a zip file. That prevents you opening it accidentally and changing the backup before you realise it was the backup. This way you always have a clean backup that can be used to create a new clean copy time after time.

           

          Normally there are no warnings of things not getting imported so without knowing exactly what they were, it would appear something did go wrong so turning off the warning was not the best move as you may need that when you upgrade again. Go to File > Options and look for Do not show notifications. Click Reset All.

           

          Now check your "upgraded" project.

          1. In Project Manager do any topics or graphics have red crosses against them. If just a few, you could import them from the pre upgrade project.
          2. Look at Broken Links in Project Manager. Are there any? If so that will help you work out what is missing.
          3. Did the project use Resource Manager or Snippets? Check those.

           

          I would also check that the updates have been applied. In File > Help you should be seeing 13.0.2.334. If not and if things do look broken, it might be worth applying the updates and then upgrading again.

           

          Then, there is style (.css) issue. I don't know if the older style is being applied as they are defined by the company. I cannot use a new style.

           

          You can right click a topic to check the Properties and that will tel you whether the correct CSS is applied. In this case I would go to the Topic List and right click the one of the headings. Then you can add Style Sheet to what is showing and quickly check all topics have the desired CSS applied.

           

          Third, I want to know whether the projects done / upgraded by me in RH2017 will be compatible with older RH versions or not.

           

          With the exception of anyone using RoboHelp 2015 the answer is no. RoboHelp 2015 users can work on the project subject to some limitations described in the RoboHelp Tour on my site.

           

           


          See www.grainge.org for RoboHelp and Authoring information

           

           

          @petergrainge

          • 2. Re: RoboHelp 2017 Compatibility with Older Versions
            SrikrishnaV-TW Level 1

            Dear Peter,

             

            Thank you for providing all the information. It was really helpful. I have checked for broken links and there aren't many. I'll work around those. Resetting notifications option has also helped.

             

            The only thing that is not available (don't think it should be a major issue) is the Update to 13.0.2.334. It is greyed out. The version displayed is 13.0.0.257.

             

            Thanks again and regards,

            Krishna

            • 3. Re: RoboHelp 2017 Compatibility with Older Versions
              Peter Grainge Adobe Community Professional (Moderator)

              Wondering if your machine was set up by an admin and you do not have admin

              rights, that would explain it being greyed out.

               

              You really should apply the updates. They are important.