8 Replies Latest reply on Jan 30, 2018 7:41 PM by Jeff Arola

    RAW Smart objects

    The Andy Butler

      If I layer two Raw files as smart objects into a photoshop document with a mask and then open one of the smart objects, as soon as I try to make an adjustment large areas of white appear and cover up my tools and sliders. See photo.  If I move the mouse over the tools then they start to reappear. If I open The workflow options then things are returned to normal. They are 42 mega pixel images. I have a new Mac with 24Gb RAM.

      What am I doing wrong?

       

      Screen Shot 2017-07-26 at 12.07.27.png

        • 1. Re: RAW Smart objects
          Jeff Arola Adobe Community Professional

          Go to Photoshop CC>Preferences>Camera Raw, uncheck Use Graphics Processor, restart photoshop and see if camera raw works any better.

           

          cr.png

          • 2. Re: RAW Smart objects
            The Andy Butler Level 1

            Hi Jeff,

             

            Thank you for your interest in my issue and for your suggestion. Unfortunately unchecking the Use graphics Processor box makes no difference in this case.

             

            I have looked further into this problem and I have discovered that it only occurs when photoshop is in full-screen mode with menu bar. This mode can be toggled on by pressing the F key.

             

            (I have also observed this happening if I have a photo open in photoshop and photoshop is in full-screen mode with menu bar and I open a second file in Camera Raw).

             

            I don’t think this is unique to my iMac as I have observed it happening on other machines. I think it is likely to be a fault within the photoshop application. I wonder if anyone else can reproduce this fault?

             

            Cheers,

            Andy

            • 3. Re: RAW Smart objects
              Jeff Arola Adobe Community Professional

              If your mac has a Nvidia graphics card, it could be an issue with the driver if it's the most recent.

               

              Adobe has confirmed that there is a problem with the most recent Nvidia drivers on the windows side, so maybe that's the case on the mac side as well.

               

              Did you try turning off Use Graphics Processor in Photoshop CC>Preferences>Performance is addition to turning off in the Camera raw Preferences?

               

              Be sure when you change the Use Graphics Processor you restart photoshop for the settings to take effect.

              • 4. Re: RAW Smart objects
                Jeff Arola Adobe Community Professional

                Okay i had a chance to test it on a macbook pro running Photoshop CC 2018 and macOS High Sierra with an Intel graphics chip and i get the same results as you even without using smart objects, so i guess that eliminates Nvidia drivers as the sole cause.

                 

                I found if i turn off Use Graphics Processor in photoshop, then the problem goes away, but then one loses all the functions that depend on Open GL like 3d.

                 

                 

                cr.jpg

                • 5. Re: RAW Smart objects
                  Jeff Arola Adobe Community Professional

                  Looking into this further it seems to have been a problem before photoshop cc 2018 and camera raw 10 on the mac side like in this post.

                   

                  Camera Raw Interface Errors - Full Screen

                   

                  and here:

                   

                  update fix for adobe camera RAW using  OS X 10.10.4 ?

                  • 6. Re: RAW Smart objects
                    The Andy Butler Level 1

                    Hi Jeff

                     

                    Thanks for looking into this further. Yes, you are right disabling the graphics processor in the photoshop preferences stops this effect happening. However I think a better workaround is to toggle off full screen mode. Alternatively open Camera Raw hosted by bridge instead of Photoshop.

                     

                    I have been experiencing this problem for at least a year on a old MacBook pro Retina mid  2012 and a very old Mac pro early 2008 and just assumed it was because the hardware was out off date. So I was disappointed when I was still experiencing it on a brand new iMac. My iMac graphics card is a Radeon Pro 575 4096 MB

                     

                    Should I mark this as answered? I have discovered some good workarounds but the underlying software problem remains, which I hope will be addressed soon.

                     

                    Thanks,

                    Andy

                    • 7. Re: RAW Smart objects
                      The Andy Butler Level 1

                      Still no fix on this problem. How do I report an issue to Adobe?

                       

                      Andrew Butler

                      • 8. Re: RAW Smart objects
                        Jeff Arola Adobe Community Professional

                        You can report it over here:

                         

                        Photoshop Family Customer Community